Tantrums's profile

New Poster

 • 

3 Messages

Tue, Jul 12, 2022 4:14 PM

XCAM2 Video Quality and Network Selection

I recently got 3 new XCAM2 cameras to replace my Nest IQ indoor cameras, but I have run into issues with the XCAM2's. When viewing the LIVE feed, I get very poor video quality along with horrible audio playback. The video is very grainy and I cannot understand a word being said that the camera picked up. I come to find out that the xcam2's connect to 2.4ghz band. From what I was told, the new xcam2's support both 2.4ghz & 5.0ghz? 

How can I got about having my cameras connect to 5.0ghz band? 

Any help or advice, will gladly be appreciated.

XfinityAmir

Official Employee

 • 

6.9K Messages

1 m ago

Hello Tantrums, thanks for reaching out to us here with this concern. It sounds like we may need to get a tech out to get this issue corrected, there's no way to get the cameras on 5.0ghz without their help, this may even be an issue with signal power depending on how far the cameras are from the modem. If the signal is too weak then we would want to look into getting PODs involved to cover the area, again this is something a field tech can determine once on site but as I know we cannot adjust these settings remotely. If you'd like to get a tech out please send us a private message with your full name and street address. 

 

"Searching for Xfinity Support" won't work. To send a "Direct Messaging" message to Xfinity Support:
• Click "Sign In" if necessary
• Click the "Direct Messaging" icon or https://comca.st/3kajO4e
• Click the "New message" (pencil and paper) icon
• The "To:" line prompts you to "Type the name of a person". Instead, type "Xfinity Support" there
•  - As you are typing a drop-down list appears. Select "Xfinity Support" from that list
•  - An "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window
• Press Enter to send it
See https://comca.st/2XfS9FQ for an example.

forum icon

New to the Community?

Start Here