Tantrums's profile

New Poster

 • 

3 Messages

Tue, Jul 12, 2022 4:14 PM

XCAM2 Video Quality and Network Selection

I recently got 3 new XCAM2 cameras to replace my Nest IQ indoor cameras, but I have run into issues with the XCAM2's. When viewing the LIVE feed, I get very poor video quality along with horrible audio playback. The video is very grainy and I cannot understand a word being said that the camera picked up. I come to find out that the xcam2's connect to 2.4ghz band. From what I was told, the new xcam2's support both 2.4ghz & 5.0ghz? 

How can I got about having my cameras connect to 5.0ghz band? 

Any help or advice, will gladly be appreciated.

XfinityAmir

Official Employee

 • 

7.1K Messages

5 months ago

Hello Tantrums, thanks for reaching out to us here with this concern. It sounds like we may need to get a tech out to get this issue corrected, there's no way to get the cameras on 5.0ghz without their help, this may even be an issue with signal power depending on how far the cameras are from the modem. If the signal is too weak then we would want to look into getting PODs involved to cover the area, again this is something a field tech can determine once on site but as I know we cannot adjust these settings remotely. If you'd like to get a tech out please send us a private message with your full name and street address. 

 

"Searching for Xfinity Support" won't work. To send a "Direct Messaging" message to Xfinity Support:
• Click "Sign In" if necessary
• Click the "Direct Messaging" icon or https://comca.st/3kajO4e
• Click the "New message" (pencil and paper) icon
• The "To:" line prompts you to "Type the name of a person". Instead, type "Xfinity Support" there
•  - As you are typing a drop-down list appears. Select "Xfinity Support" from that list
•  - An "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window
• Press Enter to send it
See https://comca.st/2XfS9FQ for an example.

Visitor

 • 

1 Message

1 month ago

Having the same issues here too .Winder what the remedy is ?

XfinityMacey

Official Employee

 • 

504 Messages

Thanks for reaching out through our Community Forums page, @user_dc8790! As mentioned above, if you are experiencing issues with video and sound quality from your Xfinity Home cameras, this may be an issue with WiFi connection and how far your cameras are from your modem and touch screen. I have one camera outside that was having similar issues, but was able to resolve it by using an xFI Pod in my kitchen (halfway between the camera and my modem), and now it works great! 

 

If you would like some additional support with your camera(s), please send us a Private Chat Message, and we would be happy to help. 

Here's the detailed steps to send a Private Chat Message:

  • Click "Sign In" if necessary
  • Click the "Private Chat Message” icon (upper right corner of this page)
  • Click the "New message" (pencil and paper) icon
  • Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list
  • Type your message in the text area near the bottom of the window
  • Press Enter to send your message.

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here