U

Fri, May 7, 2021 2:18 AM

the power cord is defective and cannot be inserted into the modem

Hello, yesterday I received a kit for self-installation of the Internet xFi Gateway. However, the power cord is defective and cannot be inserted into the modem, which will prevent the modem from turning on. There are no free agents in the chat. What should I do, how to get a working power cord?
It is larger and does not fit into the modem.

Responses

EG

Expert

 • 

87K Messages

1 m ago

Concern moved here for greater exposure to actual Comcast employees. 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Official Employee

 • 

195 Messages

1 m ago

Hello, @, thank you for reaching out in our forum for help with your power cord issue and giving me a chance to help out. I can only imagine how upsetting that would be after getting ready to start using your service and run into a delay like that, but I have your back on this. The fastest way to get a new cord would be to swap it out at your local Xfinity store. If that isn't an option, we can work on shipping out the equipment once more. Which way would you like to proceed? 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

New to the Community?

Start Here