dmb229's profile

New Poster

 • 

1 Message

Sat, Nov 7, 2020 8:00 PM

Plan keeps reverting to old plan after upgrading

I was on a plan with 200Mbps internet and I used the "Change Plan" option via the xfinity website to change it to a 1000Mbps plan.  After the change, a speed test reflected the new upgraded speed.  However, now a week or so later my speed is back to the old 200Mbps and my account shows my old plan before the change.  What gives?

Responses

Official Employee

 • 

2.4K Messages

7 m ago

Hi there, Dmb229.

 

We here on the forums can check into your account and see what is going on with your Gigabit service. 

Can you please private message me your full name and service address? Thank you for posting to our forums. 
To send a private message, please click my name "ComcastMartin" then select "Send a Message" on the right side.

 

Regular Visitor

 • 

3 Messages

5 m ago

I am having this same problem, tried to change over twice and each time it has shown my new speed and the flex added to my account for about a week until it goes back to the old speed and removes the flex. I reactivated my modem on the new plan when it asked me to. Maybe I need to put the order in just before my bill comes?

Official Employee

 • 

201 Messages

5 m ago

Hi @lamp_peach , thanks for reaching out about this; it shouldn't matter when you change your plan and it shouldn't revert back to an old plan so please click on my handle (ComcastGina) and "Send a message" with your name and service address, and let us take a deeper look into this for you. We want to ensure you are receiving the services you want! 

New to the Community?

Start Here