U

Visitor

 • 

1 Message

Tuesday, March 1st, 2022 1:42 AM

Closed

No internet for over a month

After moving into a new house I ordered Xfinity on Jan. 25th.  I could not get the internet working and a tech came out Feb 7th and said a line needed to be buried.  The property has been marked by the utility companies since Feb. 11th and I was notified a line would be buried within thee days(didn't happen). I have called multiple times and each time was assured that he line would be buried by Feb. 28th at the latest.  This has not happened and I have not had 1 second of service despite ordering internet more than a month ago.  If you are unwilling to provide service let me know and I'll take my business elsewhere  and ask you to refund my money.

Official Employee

 • 

2.9K Messages

11 months ago

Hey there, @user_c1bc3f 

 

Our team wants to help out! I understand being told one thing and having the other happen is not ideal. Can you please send us your full name and full service address via private chat? To send the requested information:
  • Click "Sign In" if necessary
  • Click the "Direct Messaging" icon 
  • Click the "New message" (pencil and paper) icon
  • The "To:" line prompts you to "Type the name of a person". Instead, type "Xfinity Support"
      there. As you are typing a drop-down list appears.
  • Select "Xfinity Support" from that list. An "Xfinity Support" graphic replaces the "To:" line.
  • Type your message in the text area near the bottom of the window
  • Press Enter to send it

forum icon

New to the Community?

Start Here