edc8's profile

Regular Visitor

 • 

8 Messages

Sat, Jan 9, 2021 8:00 AM

equipment returned

Back in december, I returned equipment, two old cable boxes for new ones that comcast wanted me to replace and there still showing on my account under devices.  why?

 

i even got an email saying the return is complete but website is not updated.  i dont want to get charged for this.

Responses

Accepted Solution

Official Employee

 • 

375 Messages

5 m ago

@edc8 Thanks for taking the time to reach out to us regarding your equipment return and website updates. I am truly sorry for the delay in our response and appreciate all of your patience with us. You have come to the correct place and I would love to ensure that we get to the bottom of the system update for you. Can you please reach out through private message (this link will walk you through how

https://comca.st/2LM8yMM) with your first and last name, name on the account if different and service address?   If you’re having trouble locating this information, you can also reference our world-class MyAccount app to view all of your account details by the simple touch of your fingertips! Please follow the process here to learn how to obtain that information: https://comca.st/35XVKd5
ComcastChe

Official Employee

 • 

6.1K Messages

5 m ago

@edc8, thank you so much for taking the time to chat with us in a private message to get this taken care of. If you need anything in the future, please create a new post with details of your experience, and we will help however we can. Thank you for your continued loyalty. Take care! 🙂 

New to the Community?

Start Here