U

Visitor

 • 

1 Message

Mon, Apr 12, 2021 7:59 PM

Comcast falling apart

It has been more than three outages this week and getting tired of it Comcast is no longer the best provider if you ask me it’s constant outages always a problem I wish they was a better company to have internet 

Responses

ComcastTambrey

Official Employee

 • 

2.7K Messages

1 m ago

Hello, @user_876726! I'm glad you reached out to us here on the Xfinity Forums. With many of us working and spending so much more time online at home these days, we absolutely understand how much an inconsistent connection can get in the way. We would love to take a look and see what can be done to reduce these interruptions so that you can enjoy your services again! Please send us a Live Chat with your first and last name as well as your service address so we can assist. 

 

To send a Live Chat, please click on the chat icon on the top right of this page, next to the bell. Make sure to send the message to our singular handle "Xfinity Support" and we will get back to you ASAP.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
Again

Expert

 • 

25.5K Messages

1 m ago

@user_9f47a3 Just reset your modem back to factory settings.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Visitor

 • 

40 Messages

1 m ago

Appreciate the thought.  Did that. 2.4 light still flashing when modem in bridge mode. Funny part is, Xfinity sends new signal, the  5..0 light comes on blinking.  I have my own router, hence bridge mode is set in the modem.  Both wifi lights have been off until 5 weeks ago.   I also had Geek Squad check the modem  and was good.   Issue as finally acknowledged by Xfinity and then Arris after 5 weeks of customer torture ( lot of broken promises, dropped calls on Xfinity part).  Xfinity will not apply rollback ( sent that comment to Arris) and was told i have to wait for next update. Will believe that when it rains rocks from the sky.   I understand they have to modify some aspect of the modem to work within their system but when they alter additional functionality, well that is not acceptable.    

New to the Community?

Start Here