K

Visitor

 • 

2 Messages

Sat, Jul 31, 2021 6:18 PM

Blank Primary User After Switching Service to New Address

After switching service to my new address, my account tells me that I am a restricted user even though I am the sole, primary user on the account. When verifying my xfinity ID, it shows my username as a "user" with a blank primary user. Can anyone help me resolve this? I'm unable to set up auto pay because I can't access the billing section of my account and cannot view my bill.

Responses

Official Employee

 • 

304 Messages

2 m ago

Greetings, @kdtice! Thanks so much for taking a moment out of your busy day to leave a post on our community forum. I'm sorry to hear you're having issues with your Xfinity ID, but you have definitely come to the right place for assistance.

 

 

If you could send our team a private message with your full name, the name listed on the account (if different), and the service address associated with your account, I'd be more than happy to look into this for you.

 

 

To send a Private Message, please click on the chat icon in the top-right corner of the screen, next to the bell icon, and then type or select "Xfinity Support" to initiate a live chat.

Visitor

 • 

2 Messages

@XfinityJamesC

PM sent 

Official Employee

 • 

304 Messages

Perfect! I will reply to you there.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New to the Community?

Start Here