S

Tuesday, November 21st, 2023 3:42 AM

Closed

Being charged for an inactive device I no longer have access to since July

I lived in an apartment complex that required us to use Xfinity internet after we had been using a different provider. After moving out in June, I was instructed by the Comcast technician that helped with the installation at that apartment to leave the device for the next tenants, as he went ahead and set me up to receive a new gateway router at the new apartment. Upon setting the new device up at the new apartment, I am still being charged for the original router as well as my current router with on the bill statement with a message saying “This equipment is inactive. We’ll be happy to remove this charge once it’s returned to a local Xfinity store” The problem here is that I can’t return the device as I no longer live in the same area and was instructed by the Xfinity representative to leave the device. I have reached out to support, who said that until I returned the device, I would be charged, even after explaining the situation that I was told by Xfinity not to return the gateway. I also contacted the representative who claims to have gotten it “fixed” for a few months now, but I still have been overcharged since July. What can I do to get rid of this charge?

Official Employee

 • 

252 Messages

8 months ago

@Shortnotshort11 Could you please send our team a direct message. Our team can most definitely take a further look at this issue.To send a "Direct Message" ("Private") message:
Click "Sign In" if necessary
• Click the "Direct Message chat" icon
• Click the "New message" (pencil and paper) icon
• Type "Xfinity Support" in the "To:" line and select "Xfinity Support" from the drop-down list which appears. The "Xfinity Support" graphic replaces the "To:" line
• Type your message in the text area near the bottom of the window

forum icon

New to the Community?

Start Here