Community Forum

< Gigabit Speeds

New Poster

< Gigabit Speeds

I recently upgraded my package to the Triple Play that is supposed to have gigabit internet. I confirmed it is listed as that speed in my Xfinity account online. 

 

On my laptop I'm typically getting 60-120 Mbps speeds, once I saw 250 Mbps. I have the Arris SB8200 connected via CAT7 to a Linksys Velop system which has a built in speed test in the configuration page and when I run that speed test, I get around ~400 Mbps down/6 Mbps up.

 

My wiring cofiguration coming to my house has a splitter with one wire running to the second floor of my home via the exterior and the second going through the basement, which I then have split again to the modem and my cable box. I'm considering upgrading my cable layout so there is only one splitter between the street and the modem, but I'm not sure if it is worth it. 

 

Am I having unrealistic expecations on speeds I should be getting? The whole point of me upgrading my Xfinity package was to get faster internet because my house has so many wireless devices connected all the time. I bought a new Arris SB8200 and upgraded to the Linksys Velop and Gigabit ethernet and I feel like I'm not getting the speeds I should be. Any reccomendations?

 

Thank You,

Highlighted
Expert

Re: < Gigabit Speeds

For a test, does a computer hardwired directly to the 8200 modem have the same problem ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: < Gigabit Speeds

Unfortunately I only have a macbook with no ethernet port to try to plug it in directly, however, the router is directly plugged into it and that is only getting low to mid 400s speeds

Expert

Re: < Gigabit Speeds

No help there...

 

Start here;


https://forums.xfinity.com/t5/Your-Home-Network/Connection-Troubleshooting-Tips/m-p/1253575#M94474

 

Post the requested info from here;


https://forums.xfinity.com/t5/Your-Home-Network/Information-Requested-for-Connection-Related-Posts/m...

 

Some tips for improving WiFi performance;


http://corporate.comcast.com/comcast-voices/10-ways-you-might-be-killing-your-home-wi-fi-signal

 

http://forums.xfinity.com/t5/Your-Home-Network/Improve-Your-Wireless-Gateway-Home-Network/td-p/26276...


https://www.xfinity.com/support/articles/improve-your-wireless-home-network



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!