Community Forum

i purchase extreme pro 400 Mbps but only getting 30 Mbps

New Poster

i purchase extreme pro 400 Mbps but only getting 30 Mbps

hi

i recently purchased the extreme pro plan on 9/6/2017 and been recieving only 30 Mbps. i contacted live chat yesterday and did a few test and powercycling then ended up sending a tech out today. the tech check wiring ect in the end he told me i should get a new modem, so i bought the motorola MG7540 and i'm still only recieving 30 Mbps. just looking for any suggestion or explanation 

Tags (1)
Diamond Problem Solver

Re: i purchase extreme pro 400 Mbps but only getting 30 Mbps

Don't know what modem you had before but the MG7540 is not approved for the 400 speedtier so it defaults to using the Performance 25/5 speedtier;

 

https://mydeviceinfo.xfinity.com/device/motorola-mg7540-563

 

It's not likely that they even have a configuration file written for it for that speed. You are probably better off bringing it back and getting a modem that is approved for 400 Mbps speeds. Input your information at that site that I linked to and it will tell you which modems are compatible.

New Poster

Re: i purchase extreme pro 400 Mbps but only getting 30 Mbps

i purchased the mb8600 and it works. thank you very much eg

Diamond Problem Solver

Re: i purchase extreme pro 400 Mbps but only getting 30 Mbps

Highly regarded modem ! DOCSIS 3.1 ready if you ever decide to upgrade to gigabit speeds. Happy surfing !

Official Employee

Re: i purchase extreme pro 400 Mbps but only getting 30 Mbps

Hello Hvarg, I EG was able to assist you. Is there any further assistance you need? 

New Poster

Re: i purchase extreme pro 400 Mbps but only getting 30 Mbps

What's the upload speed you're getting?