Community Forum

Upgraded to Gig speed and dropped to 20mbps!

Highlighted
New Poster

Upgraded to Gig speed and dropped to 20mbps!

So after years of family complaining about slow internet, i upgraded, or so I thought.

Paid for 1Gigabit ethernet.  Up from 100Mbps.

Old System: Motorola Arris Surfboarrd SB6121.  Speed = 120Mbps.  Cabled.  Not wifi.

Xfinitiy support said I can't get essentially any higher because old modem capped at 180Mbps.  Get new modem.  Agreed.

Got new Netgear c7800.  Literally plug/play connect to Xfinity setup and go.

 

NEW SYSTEM: 40Mbps!!! brand new modem and download speed dropped 3x.  Upload increased 8x.   Spent hour with customer support tieir 0/1.  can't fix.  modem green on their end.  all resets.  server resets on their end.  tried everything - twice!  Nothing changed on my end.  unplugged 5 cable from old modem.  plugged 5 cables into new modem.  Should be getting 1000Mbps.  I get 40....and I"m paying extra for this!!!

 

Tier 2 service was supposed to call.  No call.  16 year customer.... Joy.

 

My guess is next they will tell me I have a bad modem out-of-box.  This happened when I upgraded from 25Mbps to 100 about 6 years ago....2nd modem same results....until Tier 2 said something like they discovered they had to flip a switch on their end....and then poof...everything worked....rather suspicous.......

 

Highlighted
Expert

Re: Upgraded to Gig speed and dropped to 20mbps!

Try calling 1-800-comcast and ask a rep to completely remove the modem from your account and to "re-provision" it from scratch. Also ask them to confirm that the provisioning and account data in their database is correct and complete and that the correct configuration / bootfile for your subscribed to speed tier is being pushed to the modem.

 

Good luck !



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Upgraded to Gig speed and dropped to 20mbps!

Thanks. But that was something they already did in Tier -0/1 services.  Sent modem new bootfile twice.

Service guy showed up today.  Left message that they found a problem outside that they needed to resolve...but the message said we would have essentially zero service for 24-48 hours while they fixed the outside issues....  So I assume that the first thing they do is make sure they can get at least 1Gbps at their drop at the street?

 

They were correct on zero internet service, as I am now at 1.4Mbps after Customer Service left.

 

So let's recap.

Day 1: 120Mbps.  Pay for 1Gbps.  Still only get 120Mbps.

Day 2: Buy new Modem.  

Day 3: Install Modem.  Get 40Gbps.  Call Customer Service.

Day 4: Waiting

Day 5: Service Arrives.  Get 1.4Mbps.

 

I'm sure there is a solid technical answer for all of this.

 

Highlighted
New Poster

Re: Upgraded to Gig speed and dropped to 20mbps!

I may have had faster internet with Netzero back in the day.....

Highlighted
Expert

Re: Upgraded to Gig speed and dropped to 20mbps!


@16yearcustomer1 wrote:

Thanks. But that was something they already did in Tier -0/1 services.  Sent modem new bootfile twice.

 

 


FWIW, that doesn't necessarily mean that the other related steps that I stated were also performed by that rep. It's very easy for them to just re-push a boot-file.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!