Community Forum

Unexpected cert error and activation request

New Poster

Unexpected cert error and activation request

Hello,

 

Last night suddenly whenever I tried to go to any HTTPS site (even very common ones like https://www.google.com) I get a certificate error (ERR_CERT_COMMON_NAME_INVALID in Chrome). After seeing that I tried disconnecting and reconnecting to my wi-fi, at which point I got a prompt to activate my XFinity service (which I've had active for at least 6 months). Unfortunately I did not try this on my desktop with a wired connection, so I don't know if the issue happened there as well.

 

Anybody know what could have caused those two things to happen? There was not any change on my side, at least not that I'm aware of. Maybe an automatic update of my modem or my router or something?

 

Thanks!

Expert

Re: Unexpected cert error and activation request

You could try calling 1-800-comcast and ask a rep to completely remove the modem from your account and to "re-provision" it from scratch. Also ask them to confirm that the provisioning and account data in their database is correct and complete.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!