Community Forum

Super slow internet speed

Regular Visitor

Super slow internet speed

My internet speed is supposed to be somewhere close to 100mbs but after a speed test, I am averaging 7mbs.  I have gone through the troubleshooting on xfinity and have reset my modem with no luck.  Can someone help?  Thanks

Regular Visitor

Re: Super slow internet speed

xfinityspeedtest.jpg

Silver Problem Solver

Re: Super slow internet speed


@robcord1980 wrote:

xfinityspeedtest.jpg


Can't see your picture.

 

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Expert

Re: Super slow internet speed

@robcord1980 wrote:

xfinityspeedtest.jpg


Can't see your pic. Since you are a new poster, it likely needs to be approved by a Forum Admin.

You could try hosting it at one of those free third-party pic hosting sites and post the link to it here.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Super slow internet speed

@EG 

Hi EG - I can see the picture.  However, it's just the screenshot of a speedtest result that shows very low numbers.

 

@robcord1980 

Hi Rob - please review this post on what information can help troubleshoot your issue:

https://forums.xfinity.com/t5/Your-Home-Network/Information-Requested-for-Connection-Related-Posts/t...

 

I know the wizards here have been able to help me based on that info, and I hope they can do the same for you! 

Regular Visitor

Re: Super slow internet speed

Thanks for the link!

I managed to get my speeds up to what they're supposed to be by disabling the xfinity router and bridging the xfinity modem with my own seperate router.

Temporary fix for now.

Silver Problem Solver

Re: Super slow internet speed


@robcord1980 wrote:

Thanks for the link!

I managed to get my speeds up to what they're supposed to be by disabling the xfinity router and bridging the xfinity modem with my own seperate router.

Temporary fix for now.


If I understand what you say, it sounds like you might be able to return the Comcast router to save $13/mo?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Regular Visitor

Re: Super slow internet speed

I do have my own modem (Motorola MB8600) and have had it connected on my account only to wake up and see that it was completely deleted from my account the next day.  Called in twice to add it back on and twice it was deleted from my account.

After the frustration, I went to the Xfinity store and just picked up a gateway (TG1682G) thinking all my issues would be solved.  Nope. On the activation site I would get a "Sorry, we can't find this device" which is when I made my last call and eventually I was online.  Hung up with the lady I spoke with at the call center and then I realized I forgot to check my speeds which is when I noticed how horrid the speeds were.

After some troubleshooting, I thought I'd try the bridging mode on the xfinity gateway (TG1682G) with my own router and here we are.  Smiley Happy

First couple of days, not so great.

I will be giving xfinity another call eventually to see if the gateway (TG1682G) has to be reprovisioned or exchanged for another.

Highlighted
Silver Problem Solver

Re: Super slow internet speed


@robcord1980 wrote:

I do have my own modem (Motorola MB8600) and have had it connected on my account only to wake up and see that it was completely deleted from my account the next day.  Called in twice to add it back on and twice it was deleted from my account.

After the frustration, I went to the Xfinity store and just picked up a gateway (TG1682G) thinking all my issues would be solved.  Nope. On the activation site I would get a "Sorry, we can't find this device" which is when I made my last call and eventually I was online.  Hung up with the lady I spoke with at the call center and then I realized I forgot to check my speeds which is when I noticed how horrid the speeds were.

After some troubleshooting, I thought I'd try the bridging mode on the xfinity gateway (TG1682G) with my own router and here we are.  Smiley Happy

First couple of days, not so great.

I will be giving xfinity another call eventually to see if the gateway (TG1682G) has to be reprovisioned or exchanged for another.


I exchanged my XB3 for the XB6 because I knew Gigabit was going to be available in my market at no extra cost to me.  I am now a Gigabit happy camper.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Official Employee

Re: Super slow internet speed

robcord1980, thanks for posting here! I see you were able to get your speeds back up by using your own router. I am happy to look into the issue you had before. I'd like to make sure your signal levels are in spec and if there is an underlying issue here. I see your message to Shane so I'll follow up there. 

 

KenF


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!