Xfinity plant
Community Forum
Xfinity globe

Speed not as promised

New Poster

Speed not as promised

Customer for about 10 days.  Signed up for 75 MBps plan, and upon installation, we were getting better than this level of speed.  One day later it dropped to 45.  After a week of very spotty service, including several drops, I called for help.  In the day prior to the service call, I had tested my speed under both no usage and moderate usage, and in all cases it came in between 20-31 Mbps.  So xfinity shows up, checks connections, runs a few tests, and it magically spikes to 85 Mbps (although usage was at zero).  No problems with the feed, connections, or equipment he says. 

 

At this point he leaves and I played an online FIFA game through Xbox One, and it drops to 45.  That's too much of a drop for one online game, but ok I can at least attribute slower speed to something.  So I again turn all usage of internet and test.  Goes down to 40 Mbps now, and this is less than an hour after the technician left.  Test again, drops to 26 at zero usage.  Test one more time that evening, get 45.  Test first thing this morning (again no usage) and it's at 47.  In no case am I getting near the 75 MBps I'm paying for. 

 

Two things strike me as odd: 

1.  The only times I'm getting what I paid for is when the technician is at the house.  Hate to sound conspiratorial, but it seems like I somehow get a boost when they're on site.  It's like they know we're going to test.  

2.  Using very little capacity seems to be a sudden huge drain on my total speed.  It's like it's a very unstable signal to the neighborhood.

 

FYI I use a SB 6141, brand new with a TP-Link AC 1750 wireless router, also brand new.  

 

Has anyone elsed experienced something similar?  I have two weeks left in my 30 day money back guarantee, and pretty sure I'll cancel and go to the other provider if this continues.

New Poster

Re: Performance Pro Houston Area upgrade

I'm having same issue.  I just signed up for 75 and get, under best cases, about 45.  Has to be feed to your neighborhood, no?

Contributor

Re: Speed not as promised

I just had a similar issue resolved a few days ago.  Every time it would rain, my internet speeds would be much slower than they should be, or hardly functional at all.  Turned out there was heavy damage to the lines around my home due to squirrels chewing though the lines and exposing the insides to the elements.  Once that was fixed, my service returned to normal.

 

It could be a lot of different things though.  Did it happen to be raining when you experienced those speeds?  If so, might be something to check out.

Official Employee
Moved:

Re: Speed not as promised