Xfinity plant
Xfinity globe
Community Forum

Slow websites, fast internet?

New Poster

Slow websites, fast internet?

So long story short, I have a nice newer gaming laptop (running Win10) and a nice new gaming router with Xfinity high speed (Blast, maybe?  Speed tests typically show 70-80mbps).  Download speeds, pings to various addresses and in-game latency is great.  Problem is about half of the websites I visit display unusably slow load times, most notably facebook and youtube but also various others.  Problem does not manifest on other network devices and resolves if I turn my VPN on.  Multiple virus and malware scans show clean.  No other symptoms or problems.  Drivers up to date.  Tried ISP, google and OpenDNS without change.  I'd love to hear any thoughts or suggestions!

Problem Solver

Re: Slow websites, fast internet?


@JoshGR wrote:

So long story short, I have a nice newer gaming laptop (running Win10) and a nice new gaming router with Xfinity high speed (Blast, maybe?  Speed tests typically show 70-80mbps).  Download speeds, pings to various addresses and in-game latency is great.  Problem is about half of the websites I visit display unusably slow load times, most notably facebook and youtube but also various others.  Problem does not manifest on other network devices and resolves if I turn my VPN on.  Multiple virus and malware scans show clean.  No other symptoms or problems.  Drivers up to date.  Tried ISP, google and OpenDNS without change.  I'd love to hear any thoughts or suggestions!


      Use your TV remote to reboot the gateway. (Scroll to the gear...settings...resend signal to gateway) Good luck!