Community Forum

Slow internet on specific devices.

Frequent Visitor

Slow internet on specific devices.

Hi, I just got my xfinity internet up & running. We went with the 150 mbps package.

A problem arose as soon as the technician ran a speed test on our main computer. It was receiving about 22 mbps max . This computer is hardwired with an ethernet cable.

My desktop tests for about 50 mbps & is also hardwired.

When i plug either ethernet cable into my laptop, i get more than 150 mbps. 

I guess its safe to say that the ethernet ports seem to have issues on our desktops, but what exactly could be the issue? I updated both realtek controller drivers to the most recent revision. 

Our previous internet service would show speeds up to 75 mbps. 

Wifi speeds are great. 5G gets more than 150. 2.4 gets about 50 mbps. 

I'm unsure on how to proceed. It's amazing to see the high speeds, but it's irritating that we can't have them on our main desktops. 

Any help would be appreciated! 

Silver Problem Solver

Re: Slow internet on specific devices.


@DaveRass wrote:

Hi, I just got my xfinity internet up & running. We went with the 150 mbps package.

A problem arose as soon as the technician ran a speed test on our main computer. It was receiving about 22 mbps max . This computer is hardwired with an ethernet cable.

My desktop tests for about 50 mbps & is also hardwired.

When i plug either ethernet cable into my laptop, i get more than 150 mbps. 

I guess its safe to say that the ethernet ports seem to have issues on our desktops, but what exactly could be the issue? I updated both realtek controller drivers to the most recent revision. 

Our previous internet service would show speeds up to 75 mbps. 

Wifi speeds are great. 5G gets more than 150. 2.4 gets about 50 mbps. 

I'm unsure on how to proceed. It's amazing to see the high speeds, but it's irritating that we can't have them on our main desktops. 

Any help would be appreciated! 


You can try this:

https://forums.xfinity.com/t5/Your-Home-Network/Video-10-things-you-can-do-right-now-to-fix-your-int...

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Problem Solver

Re: Slow internet on specific devices.

Could be your ethernet cards or ports in your desktops do not support the higher speed.  You should be able to google your ethernet card or desktop to see the specs to verify.

Joe V
(not a Comcast employee, just another paying customer)
Frequent Visitor

Re: Slow internet on specific devices.


@jav6joev wrote:

Could be your ethernet cards or ports in your desktops do not support the higher speed.  You should be able to google your ethernet card or desktop to see the specs to verify.


Possibly on the main family computer, but mine is fairly new. 

ASUS P8Z77-V LK: 

Max LAN Speed 10/100/1000Mbps. But she (motherboard) has been running for more than 5 years now. Maybe she's retiring. 

 

Frequent Visitor

Re: Slow internet on specific devices.

So i did a complete Windows re-install & that fixed the issue. 

Thanks for nothing everyone!