Community Forum

Routing problem from wired device to wireless device

Regular Visitor

Routing problem from wired device to wireless device

Hello,

 

I'm having issues with routing traffic from wired devices to wireless devices on my home network using Comcast's Technicolor DPC3941T cable modem.

 

When I try to open a TCP connection from a wired device on the network to a wireless device on the network, the packets are never delivered to the wireless device.  The wired device goes through a lengthy sequence of timeouts and packet re-sends, and eventually attempts targeted ARP requests directly to the wireless device, which also fail to get a response.  Eventually, after around 15 seconds of messing around, the wired device gives up and sends a broadcast ARP request to the entire network.  The wireless device responds properly and traffic can then move normally.  After terminating the connection and waiting for around 5 minutes, the router "forgets" where the wireless device is again, requiring the entire timeout and ARP request sequence again to initiate a new connection.

 

Wired-to-wired connections work correctly, wireless-to-wireless connections work correctly, and wireless-to-wired connections work correctly.  It is only wired-to-wireless connections that lose the ability to route traffic after 5 minutes.  I've tried several different wired and wireless devices, and this only appears to happen when the wireless device is relatively "quiet" and doesn't regularly broadcast all sorts of junk onto the entire network.  I've confirmed to the best of my ability what is going on with a packet sniffer.

 

To me, this smells like something screwy with the firmware on the cable modem.

 

Thanks,

Dave

 

Expert

Re: Routing problem from wired device to wireless device

Have you first tried powercycling / re-starting the device ? No joy ? Try hard resetting the device to factory defaults by pressing and holding in the recessed reset button on the rear for 30 seconds. This can sometimes clear up some weird behavior issues. You will lose any customized settings if you do the latter and they will need to be re-configured from scratch.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Routing problem from wired device to wireless device

Thanks for the reply.  I had power-cycled the router, but it didn't help.  I had not done a hard-reset to factory default settings, so I went ahead and did that just now.  No help there either.  It still loses the ability to route from wired to wireless after 5 minutes of inactivity.

 

Thanks,

Dave

Expert

Re: Routing problem from wired device to wireless device

Maybe it's malfunctioning ? Try getting it swapped out for another. Good luck !


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Routing problem from wired device to wireless device

Thanks.  Honestly, I'm not excited about having to do battle with the front-line support to convince them that there's actually a problem, and that I would need to exchange the router.

 

And, it's my belief that this isn't a hardware issue, so swapping it shouldn't fix anything.  If it was doing something like hanging randomly or resetting randomly or failing to route all packets or corrupting data, I could believe that it's hardware.  The fact that this is a very specific, perfectly repeatable, failure of a very small subset of its capabilities, and the fact that it always loses the routing info for the wireless devices after precisely 5 minutes of inactivity, this smells like a firmware issue to me.  Somebody programmed that 5 minutes in there.

 

Are there any alternatives?  I'd love to hear from someone who works on the firmware for these, or from someone in their orbit who can offer advice.

 

Thanks,

Dave

Expert

Re: Routing problem from wired device to wireless device

O/k well nothing ventured, nothing gained..... You might get a different model with different firmware.. Again, good luck !


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: Routing problem from wired device to wireless device

Hi there, djglaze. I want to help improve your experience. I work directly for the corporate office. 

Can you please private message me your full name? Thank you for posting to our forums. 

To send a private message, please click my name "ComcastMartin" then select "Send a Message" on the right side.
 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: Routing problem from wired device to wireless device

Hi there, djglaze. 

 

It has been a while since I last heard from you via private message. 

 

If you have any other questions, please feel free to reach out to us again! 

 

Thank you for posting to our forums! 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!