Community Forum

Router can't get an IP address

Highlighted
New Poster

Router can't get an IP address

This suddenly stopped working a couple nights ago, but had been working fine for months. I've talked to three different agents and been through phone attendant heck half a dozen times, and haven't gotten any closer to a solution.

 

I have factory reset the modem. I have factory reset the router. I have tried a different router. I have replaced the cat 6 cable between the router and the modem.

 

If I connect a laptop to the modem directly, I can get an IP address and get online without issue. If I connect a router (and I do power cycle the modem in between) it just doesn't seem to be able to connect to the DHCP server to get an IP address. I show all zeroes, and no matter how many times I release and renew, I am no closer.

 

Suggestions? I'm waiting for a call back, but I don't expect it soon, what with the pandemic. This is making it nigh impossible to work or get schoolwork done.

 

Arris SB6183

TP-Link AC1750

Highlighted
Expert

Re: Router can't get an IP address

As a work-around, If you have a router that has a MAC address cloning feature, you can clone the MAC address of the computer that works in to it. This will trick the modem in to thinking that the computer is connected to it rather than the router. Good luck ! 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!