Xfinity plant
Community Forum
Xfinity globe

Re: Slow upload speeds

New Poster

Re: Slow upload speeds

several people in chicago burbs having this sporatic issues with both download and upload.  I know both my neighbors on either side are having the exact same issue I am am having as I've gone over and done various tests (speed test, reset modem, etc.)

Called into support, do the playbook (reset modem, provision, etc.) and hour plus later, no better.  I guess we are supposed to pay hundreds of dollars to comcast (we all have Extreme 150) with inconsistent speeds like 4 Mbps upload and .3 download, then 80 Mbps and 4 Mbps and anywhere in-between - never consistent like it was before with them.  I believe it has to do with recent X1 upgrades that I have noticed on the boxes.

Shame cause this poor tech support 

Expert

Re: Slow upload speeds

Start here: troubleshooting guide. If you still need help, please post your equipment details (make/model of your modem/gateway/router) and a screenshot of your signal levels and your error/event log. Thank you! 



"Keepin' it clean since '09"
I am not a Comcast employee, just a moderator.
Official Employee

Re: Slow upload speeds

Hello @snil. I can assist in further troubleshooting your upload speed issue. I'd like to start with polling our CMTS from your modem see what the stats look like. I'll also evaluate the firmware version for you. Please send me a private message and include your full name and account primary phone number so I can access your equipment.

Frequent Visitor

Re: Slow upload speeds

Sent info.

 

Thanks

Official Employee

Re: Slow upload speeds

Thanks snil. I have received and responded to your private message. Let's take it from there. Thank you.