Community Forum

Re: Not getting 150mbps and only getting around 25-40 mbps

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps


Call 1-800-comcast and ask a rep to *roll and re-provision* the modem. Also ask them to confirm that the provisioning and account data in their database is correct and complete and that the correct configuration / bootfile for your subscribed to speed tier is being pushed to the modem.

I just switched yesterday from RCN where we had 50 Mbps internet and always got 50 whether wired or wireless.  I was lured in by the 150 Mbps Blast internet, but am only getting <100 wired and about 50 wireless.  I called Comcast and had the rep do what you recommended above.  He said everything was correct but he updated the bootfile anyway.  He scheduled a tech appointment for Saturday.

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

Review this sticky

 

http://forums.xfinity.com/t5/Home-Networking-Router-WiFi/Making-sure-your-computer-laptop-can-suppor...

 

First for full speeds wired, you need a gigabit network card in your computer, many, even brand new ones only have 100 adapters in them.

 

There are a lot of computers that won't do full speeds wifi and have lower speed wifi adapter hardward, configuration and driver issues.  There is a good possibility it's the comptuter and not the Comcast connection.

 

We see it here all the time.  Please share details on the wired and wifi adapter cards in you computer as a start.  Share the model of the gateway.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Thank you.  I updated my signature with my current settings.  We also have a couple of android phones and iPhones in the house.

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

Make sure you have placed your gateway in full bridge mode as a start.  Connect the router to LAN port 1 to use your own router and not cause a double NAT condition.

 

There are many configurations of your laptop, the best I can tell it does only have a 10/100 wired adapter, so you will never get more than close to 90 speeds.

 

The wifi adapter might be a Dell 1707 adapter which is a B/G/N 2.4 card.  It might take some doing to get any real speeds out of it, you might get 70 down with updated drivers and configuration.

 

Once the rourter is configured properly, you might want to look into a USB dual band A/C adapter instead of using the internal adapter and connect to the 5.0 network on the router.

 

 

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Router is connected to LAN port 1 of gateway. How do I access the gateway to check if gateway is in full bridge mode?  Thanks.

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

You should be able to get into the gateway with your browser either at http://10.0.0.1 or http://192.168.100.1 and use admin for the logon and password for the password.

 

You can also tell by what IP your router is getting on the WAN side, if it's a 10.0.0.x address, the gateway is not bridged.  If it's a Comcast public  IP, then the gateway would be bridged properly.

 

 

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I hit a snag.  The gateway crashed when I was attempting to enable the bridge.  Now I don't have any internet at all - wired or wireless.  I am using my cell phone as a hotspot to type this.  I tried resetting the gateway but that did not help.

 

What should I do now?  Thanks and Merry Christmas.

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

Press the indented reset button on the back panel for over 30 seconds to get the gateway back to factory default.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Ok thanks. Got gateway working again as a modem and router. Disconnected my ASUS AC router until Comcast comes to check my speed tomorrow.

My uncle was telling me at dinner that he has the same gateway as me but he doesn't need to have his phone line plugged into it. He said that he has a separate phone box in his basement that Comcast installed. What is this that he is talking about?
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

There are installations where you can use one device for phone only and one for internet only.  This depends on the wiring in the home and how easy it is to backfeed the dial tone into the inside phone wiring.

 

As an example, if you had the gateway in the upstairs bedroom where the computer is, but there is no phone jack in the room to backfeed the dial tone, then that would be an example where the installer would place a 2nd device for the phone only near where the phone wiring is terminated or close to the interface box on the outside of the home.  Each home is wired differently, but for most there is both a coax jack and a phone jack in the same room so the inside phone wiring can be accessed close by.

 

A 2nd example would be when there is a home alarm where the installer needs access to the line side of the RJ31X for the alarm panel so the panel can dial out.  In this case the installer might not have any choice but to place the telephone modem near the jack for the alarm panel so the panel can seize the line.  Having the gateway here might very well have a difficult time to give the customer a good wifi or wired connection.  Then a 2nd unit would be installed in a prime location for the internet services.                            

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Yeah, he has a big house.

We only have 1 cable TV in the living room, but there is no phone jack there. The only phone jack on the first floor is in the kitchen, but there is no cable line there. The only room with a cable line and a phone line is the master bedroom on the second floor, where we have the gateway.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Hi,

Comcast tech came and proclaimed that our service is good.  He plugged his MacBook into my ethernet and got 180 down.  He said that he preferred my ASUS router over the gateway.  So after he left I enabled bridge mode on the gateway and reconnected my router, but I can't get any internet through the router.  What am I doing wrong?  Thanks!

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

When you switch from router mode to bridge mode, you need to power cycle the gateway so it reconigizes the new router, which must be on LAN port 1 of the gateway.

 

You might want to fully reset the router and start over with that too.

 

Now you can work on getting faster speeds now that it's the laptop's issue.  Look at those USB AC wireless adapters as a start.  I see it all the time now that the Comcast internet speeds have passed up the computer hardware's capabilities.

 

Good luck.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Still have limited connectivity. Router can't detect internet connection status.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

Plug in the laptop's ethernet port directly to the LAN port 1 and power cycle the gateway and see if you can get to the internet as a test.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I just reset the gateway again and disconnected the router.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I can get internet with Ethernet in Port 1 as long as the bridge is disabled.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I am just using the gateway at this point for wired and wireless internet. I've used up too much time over the holiday trying to enable the bridge on the gateway and install my ASUS router. I give up for the moment.

I appreciate all of your help nonetheless.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

If the bridge mode is off and your in router mode, then you should be getting a 10.0.0.x IP address on the computer on any and all of the 4 LAN ports.

 

If your getting a public Comcast IP on LAN port 1, then it's in bridge mode.

 

In Windows, go to run and type in cmd and run ipconfig and see what the computer's getting for an IP address.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

With bridge mode disabled, I plugged laptop into LAN port 1 of the gateway and ran ipconfig.

 

IPv4 address was 10.0.0.231.

 

ASUS router is not in use.

 

 

 

 

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

OK, now put in in bridge mode and power cycle the gateway and see what you are getting.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I need steps to get my ASUS router attached to LAN Port 1.

1. With laptop connected to LAN Port 1, login to gateway and enable bridge mode.

2. Power cycle gateway.

3. ????
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

Step 3, test speeds with the computer connected to LAN port 1.  Check that your getting a Comcast public IP.  Start / run / type in cmd.  The DOS box comes up.  Type in ipconfig and see what IP address your getting, it must be anything but a 10.0.0.x IP range.

 

If your getting a public IP, then connect the router to LAN port 1, power cycle the gateway and configure the router.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Ok, I've completed steps 1-3, and have a public IP address. 

 

So I will attempt to configure the router again.  Wish me luck.  Thanks.

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

ASUS router is connected but I still have limited connectivity. The error message is "Windows could not automatically detect this network's proxy settings."
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I power cycled gateway again and now success. Thanks!
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

Can you access the router's settings and look in the WAN side, see if it's getting a Comcast public IP address, DNS and gateway settings?

 

If ther router is set on automatic or DHCP, then power cycle the gateway again.  The router must pick up the public IP network settings passed through the gateway so the computers get internet access.  Is the WAN LED on the router on or blinking?

 

If your on the network map page on the router is internet status connected or disconnected?

Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

OK, so it's working?

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Yes so far. I just need to test the wireless speed on my daughter's GS5 when she gets home. She was able to get 178 Mbps wireless through the router on the gateway yesterday. If she gets comparable speed from the ASUS router then I will know for sure that it's working.

I'll check back later.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

All seems good. She got 164 Mbps on her phone.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I bought a D-Link DWA-171 Wireless AC USB Adapter:

http://support.dlink.com/ProductInfo.aspx?m=DWA-171

 

I'm up to 80 Mbps using the 5 GHz band. 

http://www.speedtest.net/result/5005902165.png

 

Do you think this is as good as I will get on this old laptop?

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

D-Link hasn't released a Windows 10 driver yet, so maybe the 8.1 driver is good enough.  Check the adapter settings and look under the advanced tab for wireless mode settings or other settings to confirm your on AC and not on auto.

 

Keep checking D-Link for when the Windows 10 driver is released.

 

 

http://support.dlink.com/ProductInfo.aspx?m=DWA-171

http://support.dlink.com/FAQView.aspx?f=MRBldvYIZ9JH35rXze0xbQ%3d%3d

 

I think you should get full speeds if the driver is correct and the adapter settings are correct.

 

I know the Netgear A6100 AC USB adapter will do full speeds, even on a older 2008 HP laptop on Windows 10.  This adapter does have Windows 10 drivers available.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I checked the advanced tab and it was set to auto, so I changed the wireless mode setting it to AC.

 

Are there other settings I need to adjust?

 

Clipboard01.jpg

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

My laptop crashes when I reboot with the D-Link adapter plugged in.  It seems to be ok if I unplug the adapter before restarting.  I just plug it back in when the windows login screen appears.

 

I just speed tested again and got 118 Mbps.

http://www.speedtest.net/result/5006142933.png

 

Do you think that D-Link will update drivers soon?  Otherwise, I'll have to return the D-Link and buy the Netgear adapter that you suggested.  Thanks for your help.

 

 

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

I have no idea on when the drivers will be updated as they should have been done by now, but you might want to return it for the Netgear.

 

Good luck!

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I just ordered a Netgear A6100 AC USB adapter.  Thanks!

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I installed the A6100 and got 128 Mbps after enabling AC in the wireless mode tab.  Is that as fast as I should expect? 

 

 

Thanks!

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

It's hard to tell if your going to get anything faster, but I believe you should be somewhat faster.  Now is it the router settings, the computer / OS or the wifi adapter settings, I don't know what else to recommend.

 

I just upgraded to 150 speed tier and on wifi with the A6100 I am getting 179 down on a 2008 HP laptop with a fresh install of Windows 10 pro.

 

Here's my settings

 

Enable Adaptivity - auto

QoS Support - Support QoS

USB SF Mode - disable

USB Switch Mode - Auto

VHT 2.4G IOT - Disable

Wireless Mode - IEEE 802.11 ac

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Thanks. I don't have the two USB modes that you have.

I don't know what settings to check in the router.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

Double check the driver version.

 

Screen Shot 2016-01-20 at 8.44.01 PM.png

 

Screen Shot 2016-01-20 at 8.46.33 PM.png

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

That's the driver version that I have.
Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I almost got 150!

 

http://www.speedtest.net/result/5021001241.png

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

OK, that might be topped off for your setup.

 

 

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

A problem that I have now is that my wireless HP MP printer is on the 2.4 band.  What solutions do you recommend to be able to print to it?  How would it work if I USB the printer to the router?  Thanks.

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver

Re: Not getting 150mbps and only getting around 25-40 mbps

Printers are almost always on 2.4, it doesn't matter if the printer is on 2.4, the computer is on 5.0 or ethernet.  It should all communicate between the bands and ethernet in and out of the router.  You don't want to communicate using peer to peer but use infrastucture mode and as long as the printer has a IP, the computers should find it.

Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

If I go back to the old 2.4 wireless network with the built-in wireless adapter, it finds the printer.  Using the Netgear wireless adapter, I get printer offline error messages.

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

I know that I need to change something in the router's 5.0 gHz settings to allow it to see the printer, but I don't know which setting to choose.

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
routersettings.jpg
Contributor

Re: Not getting 150mbps and only getting around 25-40 mbps

Success!  I reinstalled the printer using IP address using the wireless 5 connection.  Now the printer works fine!

Arris TG1682G gateway
Asus RT-AC66U Dual-Band Gigabit router
Dell Inspiron 15 N5050 laptop
Windows 10 Home
Diamond Problem Solver
Moved:

Re: Not getting 150mbps and only getting around 25-40 mbps