Community Forum

Re: Gigabit Speed Problems with XB6 Modem

Highlighted
New Poster

Re: Gigabit Speed Problems with XB6 Modem

Hi. I am actually experiencing a very similar issue.

I have a gigabit plan and use the provided XB6 modem in bridge mode.

My edge device for a while was a system I had running Pfsense. I had no issusues with speed for over six months. I had regularly performed speed tests due to some projects I had been working on. I recently switched over to a Ubiquity edge router 4 due to the way Pfsense does NAT. I have quite a few roomates who like to play together in the same online games. Anyways, when I setup the edge router, I of course did a speed test. I was only getting 560Mb/s max. I thought that this was due to the config on the new router, so I connected my PC directly to the modem. and rebooted it. I was still only getting around 500 Mb/s. I contacted comcast, and over the past month I have had 4 techs out to my house. They have tested the lines and replaced my original modem.

after all the testing and troubleshooting we have done, the only time I am able to get my full gigabit speeds are when I have the modem reprovisioned and dont put it in bridge mode. As soon as I put it in bridge mode, I can only get around 500 Mb/s. Taking it back out of bridge mode does nothing.

It has been suggested that we try to get one of the new XB7 modems and see if it solves anything.

It was also recommended that we just downgrade our package to the 500Mb/s plan.

 

This issue has lasted for a month so far. I was able to get my bill cut in half, but it took a lot of back and forth.  We are going to go up to one of the comcast stores and see if they can provovide us with one of the new model modems.

Highlighted
Silver Problem Solver

Re: Gigabit Speed Problems with XB6 Modem

AFAIK, the XB7 is not generally available at this time.

Did you read this?

https://forums.xfinity.com/t5/Your-Home-Network/Troubleshooting-Gigabit-internet-speeds/m-p/3145413#...


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
New Poster

Re: Gigabit Speed Problems with XB6 Modem

I am having this same issue. I spoke with Xfinity and attached the chat. Apparently there is nothing they said they can do about it. This is a joke.

 

CHAT STARTED AT May 23, 2020 12:57:17 PM
12:57:17 PM BRANDON SLUSAREK : Connecting from Xfinity Assistant. I have a question about internet.
12:57:23 PM  System : You are now chatting with Anthony
12:57:31 PM Anthony : Thank you for contacting Xfinity Chat Support. My name is Anthony. How can I help? 
12:58:00 PM BRANDON SLUSAREK : I have Gigabit internet service, and for the last few months I can no longer achieve speeds over 600mbps awhile being connect via ethernet cable. This issue had started on 3/30/20 and has been an issue since.
12:58:23 PM BRANDON SLUSAREK : My speeds were between 930-948 download and around 40 upload for the past year up until now.
12:58:38 PM BRANDON SLUSAREK : I tried resetting/Power cycling
12:58:45 PM BRANDON SLUSAREK : I tried taking out of bridged mode and connect to the modem directly via ethernet from multiple laptops
12:59:00 PM BRANDON SLUSAREK : Replaced all ethernet cables with new CAT6 cables.
12:59:16 PM BRANDON SLUSAREK : And this is still an issue
12:59:38 PM BRANDON SLUSAREK : I'm to the point where I'm not sure what else to try other than replacing my Comcast XB6 gateway with my own modem.
12:59:45 PM  System : You have been transferred to queue Repair Support
12:59:49 PM  System : You are now chatting with Apostolos
12:59:55 PM Apostolos : Hello BRANDON , My name is Apostolos , Thank you for contacting Comcast! How can i help you?
1:00:12 PM BRANDON SLUSAREK : Hello
1:00:16 PM BRANDON SLUSAREK : I have Gigabit internet service, and for the last few months I can no longer achieve speeds over 600mbps awhile being connect via ethernet cable. This issue had started on 3/30/20 and has been an issue since.
1:00:26 PM BRANDON SLUSAREK : My speeds were between 930-948 download and around 40 upload for the past year up until now.
1:00:35 PM BRANDON SLUSAREK : I tried resetting/Power cycling
1:00:46 PM BRANDON SLUSAREK : Replaced all ethernet cables with new CAT6 cables
1:00:50 PM Apostolos : Ok let's take a look
1:00:59 PM BRANDON SLUSAREK : Sure thank you
1:02:05 PM Apostolos : Ok can I text a code to 8895 to access the account?
1:02:24 PM BRANDON SLUSAREK : Yes
1:02:34 PM Apostolos : sent
1:02:53 PM BRANDON SLUSAREK : 154679
1:03:47 PM Apostolos : Ok give me a few minutes to pull up some diagnostics
1:04:12 PM BRANDON SLUSAREK : Sure
1:04:16 PM BRANDON SLUSAREK : Thanks
1:04:26 PM Apostolos : No problem
1:07:03 PM Apostolos : I am showing only 2 things in the signal you have a slight noise interference issue and you have a few uncorrectable errors and internal resets on the modem
1:07:52 PM BRANDON SLUSAREK : I'm to the point where I'm not sure what else to try other than replacing my Comcast XB6 gateway with my own modem.
1:08:04 PM BRANDON SLUSAREK : It had worked flawless up until a few months ago
1:08:09 PM Apostolos : It won't help
1:08:30 PM Apostolos : Trying to see neighbor data now
1:09:40 PM Apostolos : Let me run another test for a couple minutes
1:09:51 PM BRANDON SLUSAREK : ok
1:11:08 PM Apostolos : So while my test is running I will try to explain what I see
1:12:20 PM Apostolos : you have a slight noise issue which usually is caused by lose or no compression connections that allow foreign radio frequencies to affect the cable
1:12:54 PM Apostolos : that explains the packet loss and resets within the modem
1:14:41 PM Apostolos : although within acceptable levels it still degrade the service, The cause could be anywhere from the modem to were it connects on the pole or underground
1:15:43 PM Apostolos : Right now, I would check the connections everywhere they are accessible and make sure they are tight
1:16:04 PM BRANDON SLUSAREK : I have done that multiple times. All connections are tight.
1:17:59 PM Apostolos : Right now we can not dispatch a tech for that but once we are out of crisis mode I would suggest a visit, I wouldn't waste money at this point it is a signal issue it could even be a neighborhood network issue but I am not getting solid evidence of that
1:18:43 PM BRANDON SLUSAREK : So there is nothing that can be done at this time?
1:19:04 PM Apostolos : I can see some slight issues in houses around you but nothing to require action
1:19:50 PM Apostolos : At this time no, I am a field technician with 22 years and know how to read signal
1:20:53 PM Apostolos : The network could crash next week for example but I can't see that right now
1:22:09 PM BRANDON SLUSAREK : So what you are telling me is I need to "deal" with this issue while I'm paying for gigabit service and not receiving it and there is nothing that can be done about it? I'm really not sure I understand.
1:22:58 PM Apostolos : Are you getting over 600?
1:23:27 PM BRANDON SLUSAREK : Between 490-600.
1:23:40 PM BRANDON SLUSAREK : Typically in low 500 range.
1:23:52 PM Apostolos : Let me see one more thing
1:24:29 PM Apostolos : Do you have your own router looks like your modem is in bridge mode
1:25:13 PM BRANDON SLUSAREK : That is correct. I have actually tried taking out of bridged mode and connect to the modem directly via ethernet from multiple laptops with the same result. Speeds in low 500s for download.
1:25:35 PM BRANDON SLUSAREK : I have had this configuration for the past year with no issue up until now.
1:27:07 PM Apostolos : At this point there is nothing that can be done without a tech visit the seed you are getting currently is higher then the next tier I usually place expectations over 600
1:27:47 PM BRANDON SLUSAREK : Around what time are tech's going to be able to be dispatched?
1:28:22 PM BRANDON SLUSAREK : So the provisioning on the modem is correct? It an issue with cable coming into the house?
1:28:39 PM Apostolos : Right now it is only primary outlet out of service and some areas are outside check only
1:29:02 PM Apostolos : yes you have the right bootfile
1:29:49 PM Apostolos : I could be anywhere from modem to network
1:30:16 PM BRANDON SLUSAREK : It's definitely an issue to the modem at this point.
1:31:07 PM Apostolos : I can't know we need local inspection to determine
1:31:50 PM BRANDON SLUSAREK : So I can have a tech come out in a few week, months, years? I was looking for a time frame of some sort.
1:32:24 PM BRANDON SLUSAREK : And how would I dispatch a tech later on? Go through this same troubleshooting?
1:32:27 PM Apostolos : I can't give a timeframe it depends on the current situation
1:32:36 PM Apostolos : yes
1:33:27 PM Apostolos : It could also correct itself if its on the network
1:33:48 PM BRANDON SLUSAREK : wow. ok it's been 2 months already.
1:35:00 PM Apostolos : I understand but sometimes fixing something that causes an outage 5 blocks away fixes your problem too, it's just not showing now
1:35:47 PM BRANDON SLUSAREK : So there could be an outage 5 blocks away that has been a outage for 2 months?
1:36:53 PM Apostolos : No, I'm not talking literally, there could be a problem brewing but it's not showing right now
1:37:09 PM BRANDON SLUSAREK : ok thanks