Community Forum

Re: Asking for help from Comcast Employee

New Poster

Re: Asking for help from Comcast Employee

I know this is an older topic, but I have been exeperiencing the exact same thing. was paying for 250mbps, only got ~90mbps.  3 calls, 2 tech visits, and still no solution.  So, I figured that if I was only going to get ~90mbps and there is no solution thehn that is what I will pay for. So I called to downgrade my service from 250mbps to 150mbps.  Gues what, now I get 60mbps. Seriously, what is going on. Modem is brand spanking new, released 5.4.19 NetGear CM1200. Still no love.

http://speedtest.xfinity.com/results/1557785469894_JVMX8X8ZRXWUF7L

Expert

Re: Asking for help from Comcast Employee

Check your link, it is broken.

 

Start here;


https://forums.xfinity.com/t5/Your-Home-Network/Connection-Troubleshooting-Tips/m-p/1253575#M94474

 

Post the requested info from here;


https://forums.xfinity.com/t5/Your-Home-Network/Information-Requested-for-Connection-Related-Posts/m...



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: Asking for help from Comcast Employee

Mr_Locke, thank you for reaching out! 

 

Sorry to hear about the speed issues you're running into. Are these speeds that you're getting over WiFi or are you hardwired directly to the modem? 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!