Community Forum

Random speed drops [Gigabit]

Frequent Visitor

Random speed drops [Gigabit]

So I used to have 250 Mbps speed for about 4 months and it was working fine. I received an offer to upgrade to gigabit speed and I upgraded. Since I have upgraded to gigabit and my internet is not stable at all. I had many technician visits but they could not find any problem with my connection, everything is looking good. I can get 1 gig speed most of the time but the problem is random speed drops and disconnection. It happens randomly and some days more than other days. Some days I cannot even use the internet because of the disconnection and some days it works just fine. It has been more than two months now and still, no one knows how to fix it. I appreciate any help thanks!

 

Speed test, as you can see the speed drops massively.

https://imgur.com/TgCKfeo

 

Upstream and Downstream

https://imgur.com/dYCn9QD

Official Employee

Re: Random speed drops [Gigabit]

Hello, ABA444. Thanks for reaching out to us on the forums. I apologize to hear of the issues you are running into with the internet speeds. That's certainly annoying! I would like to look further into this and see if I can spot anything that may be going on. Can you please send me a PM with your first and last name so I may further assist you?

 

To send a private message, please click my name "ComcastMichael" then select "Send a Message" on the right side.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Random speed drops [Gigabit]

Sorry for posting only 5 channels. 

 

Here are all the channels and modem information.

https://imgur.com/QpgMDAu

Frequent Visitor
Bronze Problem Solver

Re: Random speed drops [Gigabit]

Edit


I am a Retired Official Comcast Employee and no longer actively support the Xfinity Forum.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Frequent Visitor

Re: Random speed drops [Gigabit]

I had many technicians checking the cables outside and inside they all said it was fine. They only checked it after I upgraded to gigabit because before it was completely fine and I didn’t have any issues.
Frequent Visitor

Re: Random speed drops [Gigabit]

I had a technician today, he checked everything and lowered the downstream power level. Sadly i’m still facing disconnecting and speed drops. Can anyone help me please.
Thanks,
Silver Problem Solver

Re: Random speed drops [Gigabit]


@ABA444 wrote:
I had a technician today, he checked everything and lowered the downstream power level. Sadly i’m still facing disconnecting and speed drops. Can anyone help me please.
Thanks,

Have you tried this?

https://forums.xfinity.com/t5/Your-Home-Network/Troubleshooting-Gigabit-internet-speeds/m-p/3145413#...


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Random speed drops [Gigabit]

Yes I tried it everything is looking good. I bought netgear CM1000 to test it out I will let you know if it fixes the issue. @RobertWy
Frequent Visitor

Re: Random speed drops [Gigabit]

I bought Netgear CM1000 and all the issues were gone ! Thank you all for the help.
Official Employee

Re: Random speed drops [Gigabit]

I bought Netgear CM1000 and all the issues were gone ! Thank you all for the help.

ABA444, glad to hear it. Post again if you need further assistance. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!