Community Forum

RDP and SSH connections are lagging under port-forwarding back to home servers

Highlighted
New Poster

RDP and SSH connections are lagging under port-forwarding back to home servers

To host a pair of home servers (one Windows and one Linux), I upgraded my service plan with Xfinity and have got unlimited data under xFi Advantage program. For the first few days, I can have very smooth connection to my servers. Things suddenly changed this morning, when I first experience lagging connections, and then completely no connection at all. 

 

Let me first show you two examples of the lagging events: for one, it is during an SSH session where I was remoting back to the Linux machine running at home. As explained in the text (also copied in full below), I keep typing and will press i when I see a lag. During the typing of such a short paragraph, there were 3 noticeable lag-events that happened.

 

 

# 2019-07-10 20:34:45 
This is a test where I will be keying things continuously, and at a point, all
inputs will freeze. After that, I will keep pressing character `i` on my
keyboard. 

# 2019-07-10 20:35:14 
While, this is a longeriiiiiiiiiiiiiiiiiiiiiiiiiiiiii than I expected, but I
caught it. Those `i` are inputted after I can no longer see a reflection of my
current typing on the screen. Now, let's see if we can capture for another one.
This problem has started early iiiiiiiiiiiiiiiiiiiiiiiii today, in the morning.
And, every time when this lag shall occur, on SSH front, the connection can be
resumed rather quickly. Yet, it can produce a funny graphics on the RDP
connection (for Windows REmotesi iiiiiiiiiiiiiiiiii Windows remote
iiiiiiiiiiiiiiiiiiiiiiiii Windows remote desktop connection.) Have fun :) 

 

Link to the demo of how things are lagging in SSH connection
Xfinity_SSH_lagging_2.gifLagging SSH connection

On more example goes funnier: during Remote Desktop Connection sessions, all pixels on the screen will freeze for an indefinite amount of time (2-15 seconds), where all keyboard inputs and mouse-clicks are staged but not displayed. Later, as shown in this funny recording of my clock in the system tray, all the pixels that were supposed to get projected will fast forward and show up quickly.

 

These are my current problem, leaving the upgrade pointless as neither SSH nor RDP connection yields a stable work environment.

 

I have contacted the customer support and have got the modem replaced. The same lagging problem still persists. In total, I have spent 5+ hours on the phone, again, to debug the following list of issues:

  1. RDP connection cannot be established under proper settings on the Gateway and on both the server and the client machines
    • Solution: check if Advanced Security has been intercepting the connection in the first place. (This is an xFi feature.)
  2. SSH connection cannot be established (again, under proper settings):
    • Solutionagain, check if Advanced Security stood in your way
  3. Cannot connect to VPS servers having public IPs:
    • Personal solution: ended up replacing the Gateway all together.
    • Symptom: simple ssh server_address command cannot establish the connection when using a computer hooked up to the Gateway at home. I can connect to the VPS under its server_address using WiFi in other locations (say, office, coffee shop).

 

Please follow up and report if you observe an identical problem with Technicolor CGM4140COM (my replacement Gateway) and please advise if you know how to solve the lagging problem.

Official Employee

Re: RDP and SSH connections are lagging under port-forwarding back to home servers

Hello, llinfeng. Welcome to the Xfinity Forums.

I really appreciate you coming to us with this issue and all the effort you've put forth to providing us with useful information. 

I would like to take a more in-depth look to help pinpoint the issue so we can return you to a more reliable connection. Please send me a private message with your first and last name so I can assist. 

 

 To send a private message, click my name "ComcastTambrey", then click "send a message".


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!