Community Forum

Not getting what I am paying for

Highlighted
New Poster

Not getting what I am paying for

I just wanted to say I am disappointed in the customer service we have been receiving thought this process of getting the speeds that we are paying for. Let me start off by saying we signed up for gigabit just about a year ago and wanted to use our own modem which was a Docsis 3.1 Netgear CM1000 it only was getting around 40mbps down and 20 up which was not correct so first the tech tried to do all of the troubleshooting steps which did not work and the she decided to replace the line coming into the home which also did not resolve the issue (the tech also mentioned an issue with the cable box for the neighborhood had an issue. That was also never fixed cause it's on our property). So then the tech tried the X1 modem on the line and then we saw an increase in speed around 400 mbps down and 40 up which seemed nice at the time but still nowhere near what we are paying for but then pretty much the tech said well there we go all fixed.... It was not! So now fast forward a year later with countless days with our internet going from the 400/450 down speed to 40/20 down almost everyday and having to reset the modem due to the massive speed drops we had enough of it so decided to call and see what's going on. When I called the lady on the phone was nice but when I told her the issue all she did was reset the modem over the phone and it went back up to around 450 mbps down. She agreed that it is not right even when I told her that a family member who has the same exact plan as we do is getting a consistent 900+ mbps down through the whole day everyday. The lady on the phone said I will submit this to the back office for further support and they will contact you which it has been almost two weeks and still no call back. This is getting out of hand and I do not think this is right on xfinitys end. I expect a call and this resolved.