Community Forum

Not getting half of advertised download speeds

Frequent Visitor

Not getting half of advertised download speeds

So I was on a lower tier of service for a while, now I am on performance plus 100mbps.
In the past on the old service level of performance starter I always got about 30Mbps down/5 up. Now that I have performance plus I should be getting close to 100 but I'm still getting only 31 down/6 up, not near what the download speed should be. I have rebooted the modem, router and computer and same with WiFi devices. I also get pretty much the same speed test results if I am connected to wired Ethernet or 5Ghz wifi.

I have an Arris cm820a modem,
Linksys wrt 3200acm router,
A win10 PC with 8 core cpu, 16GB ram and Gigabit nic.
The modem is still on the approved modem list for 100mb service even though I bought it in 2013 and it's an 8x4 modem.

My internet service is otherwise solid and dependable, I just can't get the speeds promised speeds of the package in paying for now.
Anyone have ideas I can try in to figure out what the issue could?

It's bugging me and Comast can't come out when I'm there for over a week.
I am wondering if an 8x4 modem is not getting enough through put on downstream channels because there is a lot of traffic in my area of the network and if a better modem might help, like a 24x8.
Official Employee

Re: Not getting good download speeds

mike_73, thank you for reaching out here on the forums! I'm sorry to hear about the internet speed issues you're running into, but I'd be more than happy to assist. To get started, can you please send me a PM with your first and last name? 

To send me a Private Message, please click my name “ComcastAlly” and click “send a message.”


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Not getting good download speeds

Comcast contacted me yesterday now they can have a tech come tomorrow evening between 4 and 6. Hopefully they will be able to help resolve this.
Frequent Visitor

Re: Not getting good download speeds

Today I looked up how to log in to the modem and the acceptable signal strength and SNR ratings. Everything looked with in the peramaters Arris had given. There were a lot of unrecoverable errors.
It was locked on 8 down and 4 channels up. I rebooted again and still only got 30mbps down
Frequent Visitor

Re: Not getting good download speeds

Now my issue seems resolved. The tech came and looked at the wiring and was not happy that I was not exactly properly grounded and had two splices in the line to the modem. He tested the speed at the modem and it was better then I was getting through the router. Then he decided to re run the coax wire to the modem with a continuous run of cable and fix the ground issue. The service still tested poor after the router but properly at the modem. He suggested a firmware update on the router but it was up to date. So at this point I contacted linksys. They suggested to factory reset the router and run setup and try the speed test again. If this did not work then it was a hardware failure. After the reset the internet speeds after the router are now 120mbps on wires Ethernet and over 100 on 5Ghz wireless.

The issue is solved and my cable lines are also in the best possible condition to avoid future problems.

Hopefully someone with similar issues can try some of the things I did especially with the Linksys wrt router.