Community Forum

No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE HELP!

Highlighted
Frequent Visitor

No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE HELP!

I have a new Motorola MB8600 modem with gigabit service.  I thought the provisioning worked but I now see that I am not getting an IPv4 address from the modem.   I know what I am doing with networks.   I looked at the event log and see what looks like a report of an incorrect MAC address in my account.  

 

TLV-11 - unrecognized OID;CM-MAC=XX:XX:XX:XX:XX:XX;CMTS-MAC=00:01:5c:ab:3e:57;CM-QOS=1.1;CM-VER=3.1;" 

 

The CM-MAC address I redacted above is correct and matches my MB8600 modem but the CMTS-MAC = 00:01:5c:ab:3e:57 belongs to a Cadant Inc. (who is a division of Arris) so is kind of suspect.

 

I called level 1 tech support a few times and that was pretty frustrating and got nowhere.  From what I've read on the forum there are really generous Comcast reps like ComcastJohnN and ComcastChe that are helping folks like me out.  Unfortunately I don't have the ability to send private messages. 

 

Can anybody help me? 

 

Expert

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE HEL

Hi @lgmlgmlgm

Thank you for visiting the forums! 

I've asked a Comcast employee to help you. You should expect a reply in this thread. 




I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE HEL

Wow, thank you so much.  You've restored my faith in humanity!!!

Official Employee

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE HEL

Hello, lgmlgmlgm. I apologize to hear of the issues you are having with not getting IP4. I would like to see what I can do to assist you. Since you have posted one time you should now be able to send a PM. Please PM with your first and last name so I may further assist you.

 

To send a private message, please click my name "ComcastMichael" then select "Send a Message" on the right side.

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

Ha, that is nuts! Would it be ok if I sent a reprovision to the modem to see if it will replace the boot file and hopefully get that IPv4 to start coming through? This will probably have you offline for 2-3 minutes.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

Hi Michael

 

Yes please go ahead and try that now.

 

Thanks

 

Official Employee

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

Hey Luke, I apologize for the delay in response. I have sent the provisioning signal to the modem. Now we need to check to see if it's still just pulling IPv6 for you or if you are finally getting that IPv4. You had mentioned before you were able to log into the modem's admin page. Do you know if you can disable/enable IPv4 on this modem? I'm currently researching the manual on this modem.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

 

Hi Michael

 

No I'm afraid that didnt help.  And the Motorola MB8600 doesn't have an option to . enable/disable IPv4 or IPv6.

 

I was so desperate I swapped out my router with another one I had and it also did not work.

Official Employee

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

Thank you for that information. I'm looking around on the net it seems to be common for this modem to either stop bringing in IPv4 or v6 at some point. One other thing I would like to try an rule out. On the Mac, when you have it connected directly to the modem, can you go into network settings and try disabling IPv6 from there. I just want to see if this will force the Mac to pick up the IPv4 at this time form the modem. You should be able to find this setting under the TCP/IP tab of the network section.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Expert

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

Just for clarity, did you swap out a "router", or the 8600 *Modem* for another modem ? Do you have the same issue with a computer connected directly to the 8600 modem (no router in the mix) ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

It's been a long couple of days with no luck.  Thanks for the suggestions from everyone, much of which I already tried.  I'm only now catching up with the forum.  I also spent a few hours with a great level 2 tech support person but we didnt get anywhere.  We even reprovisioned the modem.  Here's  summary..  

 

I tried 2 routers and direct connections to my Macs - Ubiquiti Edgerouter PoE and Apple Airport Extreme.  When connected directly to the Mac, DHCP would initially serve up a local I92.168 IP but no IPv6 address.  After a minute or 2 it would swap that IP for a public IP and also an IPv6 address.  The interesting thing is that it DHCP does not serve up any address, Ipv4 or IPv6 when connected to either of the routers. 

 

The other interesting thing is that xfinity tech support could see my modem's IPv6 address and could not see an IPv4 address at any time - connected to Mac or router. 

 

We then provisioned an old non-gigabit modem I had and sure enough they couldnt see that modem's IPv4 address.  That modem does serve up DHCP properly to my both of my routers.  I was told to take it up with the manufacturer,

Expert

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

This *might*be the same problem that Comcast JohnN has been fixing for customers around here lately. You could try posting to him for help in this latest thread that he seems to be monitoring;

 

https://forums.xfinity.com/t5/Your-Home-Network/No-IPv4-only-IPv6-Attn-ComcastJohnN/m-p/3138477#M289...

 

Good luck !



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

Once again ComcastJohn rides in to save the day.  I'm good to go due to his help.

 

Among other things I got a lesson to never forget ---- "ALWAYS REBOOT THE MODEM WHENEVER YOU CONNECT IT TO A NEW DEVICE OR CHANGE ANYTHING IN ANYWAY, ANYHOW".

 

Thanks also to Nerdburg, EG, and ComcastMichael for all their help!

 

Expert

Re: No IPv4 address, only IPv6. Customer support won't help. Can't send private messages PLEASE H...

Not at all surprised ! Good to hear !!!


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!