Community Forum

Low Upload Speeds/High Packet Loss

Frequent Visitor

Low Upload Speeds/High Packet Loss

For the past few months since around March 2019 I been having issues where at random times (about 2 - 4 times a month) I get very low upload speeds like 20 kbps with a packet loss of 30%. Sometimes it comes for a minute and goes away other times it stays until I reboot my modem and router. The download speeds are usually never effected though and this happens on wifi and ethernet. Strange thing is this all happen after I unplugged my modem and router and all the cables back in march for a severe thunderstorm so my stuff wouldn't get fried. 

I have no splitters it's a direct feed to my modem with the exception of 2 barrels and the ground wire and I already took them apart and checked and they look good and like new still.

Things I tried: 

- Checking all cables and everything looked good

- Ran speed tests and I get the speed i'm paying for (when i'm not having an issue).

- Ran a ping test to comcast.net for 1 minute (when not having issues) and averaged around 25ms, max of 27ms with 0% packet loss

- Ping tested to my internal modem and router address and it shows 1ms no packet loss

- Factory reset my router and flashed the latest firmware

- Rebooted my modem and router

- Checked my modem signals and logs and everything always seems fine

It's difficult for me to try without a router because I use wireless everyday and this issue happens at random but last time this happen I rebooted just the router and not the modem and I still had the issue but everytime I reboot the modem and the router it goes back to normal. I'm starting to feel like it's my modem but not sure.

My modem is a Zoom 5345 docsis 3.0 and the router a Netgear WNDR4300v2 both of which I own.

The modem logs are short because I had to reboot a few days ago but those are my usual errors every now and then except the IPv6 one. I never see a change in logs during the packet loss either.

August 13 modem stats.jpg

modem logs august 13.jpg

Ping Results:

C:\Windows\system32>ping -t www.comcast.net

Pinging e7010.dscg.akamaiedge.net [23.0.29.33] with 32 bytes of data:
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=27ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=26ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53
Reply from 23.0.29.33: bytes=32 time=25ms TTL=53

Ping statistics for 23.0.29.33:
Packets: Sent = 62, Received = 62, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 25ms, Maximum = 27ms, Average = 25ms