Community Forum

IP address suddenly not being assigned

Contributor

IP address suddenly not being assigned

Overnight I lost IP connectivity.  I don't know why.  When troubleshooting I determined that I am not getting an IPv4 (or IPv6) address assigned.  There weren't any changes on my end AFAICT.  Same gear (comcast and mine) for at least 2019 .  My PC has had OS updates over the years,  but that's it.  Voice and TV seem to work fine.

 

I powercycled the leased modem [2], ran troubleshooting via Xfinity app on my Android phone.

 

I try to renew the lease manually with no luck.  Support was called and they are "restarting the modem" and other tasks I've already done.  Waiting for a call back (not holding my breath.)  

 

Any guess what to try next?  

 

[1] Arris Interactive, L.L.C. TM722G

 

Expert

Re: IP address suddenly not being assigned

First. Is there a router in the mix here ? If so, remove it from the path and connect a computer directly to the 722. Powercycle the 722 again with the backup battery removed if there is one installed. Do you get a connection now ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: IP address suddenly not being assigned

Thanks for taking the time.

 

> Is there a router in the mix here ? 

 

The cable modem is plugged directly in to my fedora 30 system.   It's a router (I run FRR for home network to access Xfinity uplink etc.) but there isn't any e.g. NetGear or other gear between the 722 and this PC.  It is directly connected and this link is what does not get a lease.

 

I'll try to power cycle the 722 again in a few hours when I have access.  I'll remove the battery, and keep it out (vs remove and adding it back) until this is all debugged. 

 

Thanks!

 

Expert

Re: IP address suddenly not being assigned

O/k. If there is a battery installed, it prevents the modem from being power-cycled, and the MAC address cache can't be cleared.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: IP address suddenly not being assigned

TL;DR - working again

 

Removing the battery from the cable modem and power cycle didn't help.  I kept the batter out (in fact it's still out.)  Rebooted the PC, no luck.  I powered down the PC, disconnected everything from the UPS and turned off the circuit breaker to the room.   Turned everything on from modem to PC Finally things came back. 

 

No clue how the lease was lost/not renewed in the first place.

 

Thanks for taking the time to help.

 

Expert

Re: IP address suddenly not being assigned

Glad you got it squared away !



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: IP address suddenly not being assigned

Hi BostonDriver88, thank you for taking the time to provide an update here and glad your issue was resolved.  Please reach beck out if you need any assistance in the future.

 

Thank you 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!