Xfinity plant
Xfinity globe
Community Forum

I am able to load HTTPS not HTTP sites.

New Poster

I am able to load HTTPS not HTTP sites.

I have had a long standing issue which comes and goes on a daily basis for almost the last three years where I am able to load some secured https websites (i.e. google, youtube, netflix) but I am not able to load common http sites (i.e. asos or play games as my connection drops). When I reset my modem I get full connectivity for a few minutes and then it drops once again. 

 

I've came across some posts on the forums by people which have faced a similar problem to mine (http://forums.xfinity.com/t5/Your-Home-Network/Can-only-browse-HTTPS-SSL-sites-Google-Facebook-not-u... as an example). 

 

I've tried restarting the router, doing a "power cycle", resetting it to defaults. I called Comcast support who restarted the router, however; neither solution worked. There are no excess/unneeded coax cable splitters in the line leading to the modem that can be eliminated.

 

It seems many people have resolved their problem by coming in contact with a forum member by the name of 'ComcastJohnN'. If any moderator knows how to come in contact with him or can help me resolve my issue it would be greatly appreciated.

Official Employee

Re: I am able to load HTTPS not HTTP sites.

 

Hello akorns, I can help you get connected to these sites and stay connected. Do you have issues loading websites while on a laptop/desktop, or do you have issues with portable devices such as your phone or tablet? If you're using a laptop/desktop have you tried using an Ethernet cable to connect to the internet? 

Expert

Re: I am able to load HTTPS not HTTP sites.

FWIW, can't see how being wired or wireless could make a difference be to the HTTP protocol ? It all goes through the same home networking router.

 

It may be a stuck / failed browser message / notification as in the message from the thread that you noted;

 

http://forums.xfinity.com/t5/Your-Home-Network/Can-only-browse-HTTPS-SSL-sites-Google-Facebook-not-u...