Community Forum

Have the problems with the Arris SB-6190 been resolved by firmware updates?

Contributor

Have the problems with the Arris SB-6190 been resolved by firmware updates?

I have a reliable Arris SB-6140 with the Performance 150 mbps speed tier. A neighbor changed their service and offered me a nearly new SB-6190 for next to nothing. Research shows that modems with the Puma chipset like the 6190 have latency and other problems so I'm curious if this was resolved with firmware or if its the actual chipset causing the issues. I tend to get around 20% faster speed (180 down/6 up) with the 6140 so I obviously have no problems nor has it ever been down. Thanks

Diamond Problem Solver
Contributor

Re: Have the problems with the Arris SB-6190 been resolved by firmware updates?

While the DSL Reports forums are interesting it appears the Comcast posts are basically stating the problem is the chipset which is concerning me since my SB6141 is very stable. And even if the 6190 was free, it seems its got problems, agree?

Highlighted
Diamond Problem Solver

Re: Have the problems with the Arris SB-6190 been resolved by firmware updates?

I wouldn't own one. And it seems that most of the regulars here advise the same. Who knows if it is fixed or if it ever will be. I have yet to see anything definitive. Not worth the risk when there are other options.

Contributor

Re: Have the problems with the Arris SB-6190 been resolved by firmware updates?

OK thanks...I'll stick with what I have rather than play games with something problematic since I don't 'need' to replace mine.