Community Forum

Getting half my internet

New Poster

Getting half my internet

I just upgraded to blast 150mbps from 25mbps. For some reason speed tests only show ~70mbps. My Modem is a Netgear C6220. Its showing a lot of uncorrectables and low power levels and something doesnt seem right. Is my modem toast? Ive tried factory ressetting it and power cycling it multiple times with no luck. I swapped the old coax and that didnt help much. There are no splitters or couplers along the line.

Capture.PNG

Diamond Problem Solver

Re: Getting half my internet

If you’re sure there’s no splitters etc, have a tech out. There’s a better chance that there’s a problem with the cable signal itself over your equipment being at fault. Both upstream and downstream are nowhere close to being in spec

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Expert

Re: Getting half my internet


@DWiz269 wrote:

I just upgraded to blast 150mbps from 25mbps. For some reason speed tests only show ~70mbps. My Modem is a Netgear C6220. Its showing a lot of uncorrectables and low power levels and something doesnt seem right. Is my modem toast? Ive tried factory ressetting it and power cycling it multiple times with no luck. I swapped the old coax and that didnt help much. There are no splitters or couplers along the line.

Capture.PNG


Can't see your pic. Since you are a new poster, it likely needs to be approved by a Forum Admin.

You could try hosting it at one of those free third-party pic hosting sites and post the link to it here.

 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!