Community Forum

Ethernet won’t connect

New Poster

Ethernet won’t connect

Since a recent power outage nothing plugged in to the Ethernet ports on my Comcast TG1682G gateway will connect to the internet. I’ve disconnected and unplugged/reset all the connected devices and done the same for the gateway as well as doing a factory reset for the gateway. The WiFi from the gateway works fine. Please help.
Expert

Re: Ethernet won’t connect

That's a rental, right? Save yourself the aggravation and just call Comcast to swap it for a different one. I've had various devices downed by power spikes and sags over the years, even with surge protectors installed. That's why I connect my sensitive electronics to UPS's nowadays.  


Comcast Experts are other customers who volunteer their time helping on the forum and have been recognized by the community. For more information on the Expert Program, please click here.
Unless so specifically stated, my opinions written herein are my own and do not necessarily reflect the views of Comcast, its official employees or affiliates.


I am not a Comcast Employee.
I am a regular customer volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
New Poster

Re: Ethernet won’t connect

Thanks for your reply and advice. I kind of suspected calling Comcast to swap it out would lead to further aggravation but I’ll give it a try. And I think you’re probably right that the device is bad. Thanks again.