Community Forum

Ethernet connected PC cannot connect to internet, but WiFi still works

Highlighted
New Poster

Ethernet connected PC cannot connect to internet, but WiFi still works

I am having an absolute monster of a time trying to resolve an issue with my XFinity Services, and I hope somebody here can help me, because the phone line tech support has not been able to assist thus far.

 

We have an XFinity gateway plus a Netgear Nighthawk Extender and two XFi Pods powering internet in our home, no additional routers. We have 3 iphones 2 tablets 1 Nintendo Switch 3 Security Cameras and 1 Networked Printer all using the wifi without significant issue.

 

My PC is the only unit in the house that is hardwired to the modem by ethernet cable, and I have a highly unstable connection. It can work fine for days on end, but then I wake up one morning, and the internet is kaput, and no amount of powercycling or restarting will restore service on the PC. This has happened through 10 service calls and 6 different modems, and nobody thus far has been able to find out what is causing me to arbitrarily lose connection on my PC.

 

Here is, to the best of my memory, the things that have been done to attempt troublshooting.

 

  • Gateway has been powercycled
  • Gateway has been restarted
  • Gateway has been replaced (repeatedly)
  • IPV4 settings have been confirmed to match what is on the Gateway
  • Other units have been connected by ethernet (a laptop, issue occurs there as well)
  • PC has been taken to other locations (a local repair shop and my place of work) and connected to internet. No issues connecting to internet at those locations.
  • Ethernet cable has been replaced. Issue persists.
  • Electrical work was done to confirm the outlets powering PC and Modem are not faulty. Electrician confirms they are working normally.

One more item of note, which Im not sure how to articulate. I can get access to some websites and not others, make some services work but not others. For example, I can access this website, and I can access google. I can NOT access any of my usual websites (reddit, imgur, facebook, etc). I can get Discord to cnnnect and read server chats. I can NOT get my game apps (Blizzard launcher, Final Fantasy 14 launcher) to connect. I can get Steam online to download games, but NOT to play them (cloud access failure)

 

I am at my wits end and out of ideas on what can be done to get my ethernet-connected device up and running with a stable and reliable connection. Any advice would be appreciated. Thank you.