Community Forum

Disable built in DHCP server on Comcast / Cisco DPC3939 combo Modem / Router

New Poster

Disable built in DHCP server on Comcast / Cisco DPC3939 combo Modem / Router

Comcast installed a new voice gateway for me today a Cisco DPC3939 or DPC 3939 Cable Modem, Router, Wireless Router Voice Gateway combo device with the words Xfinity XB3  (for the x1 platform).

 

I need to turn OFF the built in DHCP server  on this device because it will conflict with my windows DHCP server.

 

I logged into the end users administration portal on the router / modem (http://10.0.0.1) with the default username and password (which is admin / password) for this device.  I broughht up the Gateway > Connection > Status menu that shows an overviw of the basic unit functions.  Under the Local IP Network section of the screen, the default information is displayed as follows:

 

Local IP Network   Edit
Local Network: Connected
Connection Speed: 1 Gbps
IP Address (IPv4): 10.0.0.1
IP Address (IPv6): fe80::250:f1ff:fe00:0
Subnet mask: 255.255.255.0
DHCP Server: Enabled
No of Clients connected: 2
DHCP Lease Time: 7d:0h:0m
DHCP: Yes
 
I click on EDIT to try to disable the DHCP server... and I don't see any option to disable DHCP.  I can re-configure the DHCP server but I can't disable it.
 
I'm sure there is anouther interface that will enable me to change this but Comcast support was clueless.
 
I was able to turn off the Wireless networking on the device... and a few other things... but I just can't turn off the built in DHCP server on the DPC3939
 
Thanks for whomever's help on this.
 
Tags (3)
Silver Problem Solver

Re: Disable built in DHCP server on Comcast / Cisco DPC3939 combo Modem / Router

What many folks do is call comcast and have them bridge the device and turn it in to a cable modem.  then use their own router for DHCP and routing services.

New Poster

Re: Disable built in DHCP server on Comcast / Cisco DPC3939 combo Modem / Router

Thanks, for the idea.  I'll try to see if they can figure out how to do this.  I suspect this may impact the MoCA (Media over Coaxial?) functionality of the modem.

New Poster

Re: Disable built in DHCP server on Comcast / Cisco DPC3939 combo Modem / Router

Today I had Comcast put the DPC3939 into Bridge Mode...  Now I'm really stuck.

 

On my old ubee modem, I had my router configured to pull the WAN ip via DHCP from the modem.  That didn't seem to work for the DPC3939.  Based on some digging around I discovered that the local LAN ip (in bridge mode) changed to 192.168.0.1 so I set a static IP of 192.168.0.101 on the WAN interface of my router (it runs dd-wrt) and set the default Gateway to the modem's 192.168.0.1.

 

I was able to connect to the internet with this but it looks like the WAN IP address that I’m coming from is the same one that Comcast uses to administer the modem.  It has SSH open on port 22, etc.

 

None of my port forwards work (ports 3389, 23, 80, 443, etc.)  Some of these get setup via UPnP, some are static port maps and some are port translations  (where outside port x is mapped to inside host a.b.c.d on port y) these all worked like a dream before they started trying to get X1 to work.

 

because of the modem is setup my guess is it's actually nat behind nat.

 

Other notes the DPC3939 has the built-in wireless turned off.

Only my Router is plugged in to DPC3939.

 

My Comcast Digital voice can receive but not place calls!  (This has been a problem since they put the new modem in) 

 

I can't bring up the DPC3939's web interface to back up the config file... so I can restore it the next time CC fixes something!

 

HELP. 

 

I need to know what my inside setup SHOULD be in bridge mode  (IP's DHCP settings on my router WAN, etc.).

I need to know how to 'talk to' the DPC3939 when it is in bridge mode.

 

Then if I can't make the changes myself I need to find someone at CC that can fix this setup.

 

Thanks.

 

Tags (3)
New Poster

Re: Disable built in DHCP server on Comcast / Cisco DPC3939 combo Modem / Router

I just got Xfinity installed yesterday and had the same problem.  I worked around this issue as follows:

 

  • Connected just my laptop to the router
  • Under Connections -> Local IP Network
    • Changed the address of the router to 192.168.1.1
    • Changed DHCP Beginning Address to 192.168.1.254
    • Changed DHCP Ending Address to 192.168.1.254
    • Set DHCP Lease Time to Forever
    • Save Settings
  • Router reboots and my laptop gets IP address 192.168.1.254
  • Go back to Connections -> Local IP Network
    • Change DHCP Beginning Address to 192.168.1.253
    • Change DHCP Ending Address to 192.168.1.253
    • Save Settings

Now, my laptop gets it's DHCP address assigned by my Linux box.  Why did this work?  Because the Comcast router stored my original IP/MAC address "forever" as 192.168.1.254.  And now it can only give out 192.168.1.253.  So, the Comcast router doesn't get out an IP for my laptop, and my Linux DHCP server takes care of the request.

 

Now, one of my network devices will get the  IP of 192.168.1.253 from the Comcast router "forever".  So, i just connected my printer to get this IP, then configured it as a static IP in my Linux DHCP/DNS server.  At this point, the Comcast router can no longer respond to DHCP requests since its DHCP IP range is depleted.