Xfinity plant
Xfinity globe
Community Forum

Continued issues with Upload - .42Mbps Up - At wits end

Frequent Visitor

Continued issues with Upload - .42Mbps Up - At wits end

Second time in 5 weeks.  90+Mbps down, ~.40 Up.  Renders connection useless for anything but streaming and I work form home so I need to go to the library to get anything done.  A month ago it took 2 tech visits before they would admit there was an issue and they flat out told me they would not address unless enough people complained.  In that first case it took 5 days for 200+ homes to notice they were affected before they opened a ticket to address whatever issues existed with downstream equipment.  Now issue has returned and I'm getting the same song and dance, noone else has complained so it's your problem alone until enough do.  I pay $230 a month for this nonsense.  Anyone at Comcast care or should I just cut my losses and call AT&T. 

 

 

 

 Capture2.PNG

Expert

Re: Continued issues with Upload - .42Mbps Up - At wits end

I'm going to try escalating your ongoing issue to the Comcast corporate employees that are available to these boards. You should get a reply here in your topic.

Expert

Re: Continued issues with Upload - .42Mbps Up - At wits end

I've asked a Comcast employee to help you. You should expect a reply in this thread. 

 

FYI: They owe you a $20 credit for every tech visit after the first for the same problem.You can also get a credit for your service from the time you first reported the issue until it is resolved.

"Keepin' it clean since '09" --I am not a Comcast employee.
Official Employee

Re: Continued issues with Upload - .42Mbps Up - At wits end

chrisinfla, I'll take a look into your slow connection issues. Please send me a private message with your full name and phone number so I can help. 

Contributor

Re: Continued issues with Upload - .42Mbps Up - At wits end

What are the speeds your suppose to be getting? depending on your speed package that speed test could be fine. how are you doing these speed test? wireless or hardwire? you mention something about streaming devices work but nothing else? please clearify on the above to better help you

Expert

Re: Continued issues with Upload - .42Mbps Up - At wits end


matt4952 wrote:

What are the speeds your suppose to be getting? depending on your speed package that speed test could be fine. 


FWIW, that difference between their upload and their download speeds would rule out it being a "speed package issue". The upload speed is far too slow for any package that has download speeds that fast. Something is definitely wrong.

Frequent Visitor

Re: Continued issues with Upload - .42Mbps Up - At wits end

.42 Mbs upload speed hasnt been an acceptable since the early days of DSL.  If that was the download side it would take me 9hours to download a 2gb file.