Community Forum

Constantly Have to Restart Gateway

Highlighted
New Poster

Constantly Have to Restart Gateway

My connection CONSTANTLY goes in and out, forcing me to restart my gateway 5+ times a day. Replugged in cables, put modem in open area, all of it; nothing has worked.

As someone who works from home, my internet with go down and I have to restart my gateway and wait about 10 minutes for it to fire back up.

Anyone have tips on this?
Highlighted
Frequent Visitor

Re: Constantly Have to Restart Gateway

Sorry, no tips. But I can commiserate.  My WiFi connections frequently show that my devices (phones, tables, laptops) are "connected, but no internet".  Gateway restart temporarily fixes the issue.  Online diagnostic tool tells me that something is wrong that may be impacting my internet experience and offers to restart the gateway.  This just keeps happening over and over and over again.  Same thing or something different?  Preventing me from working from home, which is less than ideal during a quarantine...

Highlighted
New Poster

Re: Constantly Have to Restart Gateway

Having a similar problem.  Have to restart the gateway once per day in the morning.  Just upgraded to the new gateway and totally regretting it.  Does anyone know if using built-in gateway wifi network + having an additional wireless router could be the source of this type of problem?

Frequent Visitor

Re: Constantly Have to Restart Gateway

I don't know.  I punted and went to the Xfinity store and got a new modem.  Solved part of the problem. But I had my house wired w/ ethernet cable.  If I plug in ONLY my wife's computer to the modem, everything works fine, but if I plug in the ethernet cable that feeds the rest of the house (through various splitters, etc.) then the wifi connection on my laptop (WIN 10) and my daughter's laptop (MacBook Pro) (and sometimes our mobile phones - Android and iPhone) start connecting and dropping or just getting "connected, no internet".  I no longer have a separate router hooked up, although I used to. I did purchase a Ubiquity WAP, but it has been disconnected since I started having this problem since I couldn't get it into bridge mode w/ the Xfinity modem.

Highlighted
New Poster

Re: Constantly Have to Restart Gateway

This keeps happening to me too. Every few days my modem goes “offline” all the lights blink except the online one and you can connect to WiFi but no internet. I try to do a hard reset and use the restart modem option on the xfinity app and sometimes nothing happens. Sometimes it comes online for 10 secs. Eventually I give up and will come back hours later and it’s working. This is so frustrating! What should I do?
Highlighted
New Poster

Re: Constantly Have to Restart Gateway

I have not made it one day without having to restart the modem. I usually get 15-20 minutes into my work or streaming a show and it cuts out. My girlfriend lives a few miles away and has the same problem. I think the bottom line is that xfinity is terrible. In a year I reset my ATT Uverse modem twice.
Highlighted
Regular Visitor

Re: Constantly Have to Restart Gateway

i'M RESTARTING MODEM MORE THAN 10 TIMES PER DAY. SOON IT IS SIMPLY GOODBYE 

Highlighted
Expert

Re: Constantly Have to Restart Gateway

3 month old dead thread now being closed.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!