Community Forum

Comcast blast not getting full speed

Frequent Visitor

Comcast blast not getting full speed

Hi

 

I signed up for comcast blast today. But my speed is between 20 to 25 mbps and not anywhere close to 105 mbps. Can someone please help me solve this.

 

http://stage.results.speedtest.comcast.net/result/633913944.png

 

 

Gold Problem Solver

Re: Comcast blast not getting full speed

Please see Connection Troubleshooting Tips. If you still need help, please post the Information Requested for Connection-Related Posts.

Frequent Visitor

Re: Comcast blast not getting full speed

Hi

 

My power levels are 7 for downstream, 38 for upstream. SNR is around 43.9. I have rented a brand new modem from Comcast which DOSCIS 3 compliant

 

the below is my tracert output

 

tracert www.comcast.net

Tracing route to a1526.dscg.akamai.net [23.3.97.32]
over a maximum of 30 hops:

1 14 ms 1 ms 2 ms 10.0.0.1
2 48 ms 19 ms 41 ms c-68-63-142-1.hsd1.pa.comcast.net [68.63.142.1]

3 18 ms 17 ms 11 ms 68.85.193.145
4 19 ms 10 ms 9 ms ae-21-0-ar03.newcastle.de.panjde.comcast.net [69
.139.192.169]
5 18 ms 20 ms 18 ms pos-5-15-0-0-cr01.ashburn.va.ibone.comcast.net [
68.86.94.249]
6 77 ms 22 ms 54 ms he-0-7-0-0-cr01.newyork.ny.ibone.comcast.net [68
.86.86.234]
7 68 ms 162 ms 41 ms he-0-11-0-0-cr01.350ecermak.il.ibone.comcast.net
[68.86.86.226]
8 54 ms 53 ms 44 ms pos-0-13-0-0-pe01.350ecermak.il.ibone.comcast.ne
t [68.86.87.250]
9 38 ms 38 ms 38 ms as20940-1-c.350ecermak.il.ibone.comcast.net [23.
30.206.182]
10 39 ms 47 ms 45 ms a23-3-97-32.deploy.static.akamaitechnologies.com
[23.3.97.32]

 

Gold Problem Solver

Re: Comcast blast not getting full speed

Your signal levels and SNR are OK, but you should have multiple upstream and downstream channels -- typically 8 channels down and 3 or 4 up. Is there really only one? It wouldn't hurt to call Comcast and have them double check your modem setup. They may have got something wrong. What is the modem brand and model number? 

 

Are you measuring your speeds with a Ethernet connection or over Wifi? Have you run Shaperprobe?

Diamond Problem Solver
Frequent Visitor

Re: Comcast blast not getting full speed

Hi

I am measuring my speed over wifi . I will give a call to Comcastt customer service and updatae you.

 

Yes there are multiple channles and all have similar SNR rates

Frequent Visitor

Re: Comcast blast not getting full speed

comcast customer support put tme on hold and nevery came back. Here is my shaperpro output

 

Connected to server 80.239.142.202.

Estimating capacity:
Upstream: 669 Kbps.
Downstream: 19676 Kbps.

The measurement will take upto 3.0 minutes. Please wait.

Checking for traffic shapers:

Upstream: Burst size: 973-986 KB;
Shaping rate: 336 Kbps.

Downstream: No shaper detected.
Median received rate: 19301 Kbps.

 

Can some one suggest what can be done next.  

 

Customer support person told speed should be minimum 50 and upto 105mbps. But I am at 20 and not even 50.

Problem Solver

Re: Comcast blast not getting full speed

Make sure you plug your computer directly into the modem via a cable and check your signal.  WiFI speed don't count.

Bronze Problem Solver

Re: Comcast blast not getting full speed

Hello,

 

I just had a look at the settings on your eMTA and found some settings that needed to be changed that could potentially help with the wireless speed.

 

However, as the user above me mentioned, we also need to know the hardwired speeds so we can better help with the issue.

 

If you could get those speeds and post them, we can continue troubleshooting to see if we can improve your speeds overall.

 

Thank you

Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: Comcast blast not getting full speed

Thank you Jesse. Can you please make the changes from your side?  This is my latest speed test results

 

http://stage.results.speedtest.comcast.net/result/637617584.png

 

around 18 mbps

Frequent Visitor

Re: Comcast blast not getting full speed

@ComcastJesse.  Any updates on this please

Bronze Problem Solver

Re: Comcast blast not getting full speed

Hi there,

 

Sorry for the delay in my response.

 

The last test you did, was that test done via a hardwired connection?

Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: Comcast blast not getting full speed

Hi Jesse

 

I just did a test with hardwired connection. Speed test gives 120 mbps + 

 

http://stage.results.speedtest.comcast.net/result/643060364.png

 

But wireless gives only 20 mbps. Can you please help in fixing this issue.  I can understand if atleast i get something 60 to 70% of wired speed . It is less than 20% of wired speed .

 

i have a dell latitude laptop. E 6440 model

 

Bronze Problem Solver

Re: Comcast blast not getting full speed

Hi there,

 

The good news is that you are getting the speeds you are supposed to. But something is causing issues with the wireless speeds.

 

Give me just an evening to look into this. I may need to get you scheduled up with a tech, but I want to trun your account by someone in a different department first.

 

I will follow up ASAP.

 

Thank you!

Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: Comcast blast not getting full speed

Hello Jesse

 

Any update on my problem. I am sttill waiting for resolution

 

Regards

Diamond Problem Solver
Moved:

Re: Comcast blast not getting full speed

Frequent Visitor

Re: Comcast blast not getting full speed

Hi

I am still waiting. 

 

Thanks

Bronze Problem Solver

Re: Comcast blast not getting full speed

Hi there,

 

I had responded to you via private message on 09/26/2014 and saw that you read the message on 10/02/2014 @ 9:11PM.

 

Thanks!

Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: Comcast blast not getting full speed

Hi

YOu mentioned that you need to get someone in your support team. Were you able to get hold of some one who can help?

 

Regards

Venkat

Authorized Vendor

Re: Comcast blast not getting full speed

What modem model is this?  Are you using ethernet or WiFi?

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Frequent Visitor

Re: Comcast blast not getting full speed

Hi

 

Please refer my thread above. I am getting lower speeds often less that 20mbps and videos buffer when using wireless connection. When using Ethernet connection speeds are fine.

 

I am having the latest Comcast provided DOSCIS 3.0 modem.

Problem Solver

Re: Comcast blast not getting full speed

What is the exact model number????

Frequent Visitor

Re: Comcast blast not getting full speed

Its Technicolor TC8305C

Frequent Visitor

Re: Comcast blast not getting full speed

Hi
Any update on this
Frequent Visitor

Re: Comcast blast not getting full speed

HI 

 

Any updates on this

Frequent Visitor

Re: Comcast blast not getting full speed

Hello Jesse or Nick

 

Any update on this

Bronze Problem Solver

Re: Comcast blast not getting full speed

Hi there,

 

I apologize. I didn't realize I wasn't receiving updates to this conversation.

 

If you're still not getting the speeds, I would recommend we have our advanced support look into thos issue. I will provide you details on the next course of action in a private message shortly.

 

Thanks

Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Regular Visitor

Re: Comcast blast not getting full speed

I am having the same issue.  I just purchased an AC1750 Dual Band Wireless Router.  I have blast internet with Comcast.  The wireless is Ping 11ms Download 43.19 Mbps Upload 12.24 Mbps.  I connected the modem directly to the computer and the results were not much different Ping 11ms Download 41.09 Mbps Upload 12.14 Mbps.  The Modem model I have from Comcast is ARRIS TM822. I feel if I am paying for Blast it should be more than what I am currently getting (speed wise not money wise). 

New Poster

Re: Comcast blast not getting full speed

Same issue here,
27 down 12 up
Not anywhere near 50 mps
Many phone calls with nothing but headache
New Poster

Re: Comcast blast not getting full speed

When I upgraded to Comcast Blast, I went from 20mbps to 40mbps. I called Comcast and found I had an old v2 modem. So I upgraded my modem to a V3 and upgraded my router to a new gigabit tplink router, Now I am connecting at 95mbps by any computer connected to my router by wire and I am connected at 70-80mbps on my N wireless. That's what worked for me.

New Poster

Re: Comcast blast not getting full speed

I have been on Blast since April 2014 in Delaware. The speed has now dropped to 7MBS upload and 10MBS download. Comcast technician came today and got similar results. Signal is good, says we are on a termination tap. We have one split to get to the modem which is a Motorola Surfboard Xtreme approved by Comcast for Blast or higher service.

I also had Blast service in Cambridge MD for several years and had no such problem there with the same type of equipment.

All wifi equipment is capable of supporting 100 MBS speeds, so it is not the wifi. Especially since the same wifi equipment worked great in MD.

New Poster

Re: Comcast blast not getting full speed

I had a similar experience in Maryland. No so in Delaware with same equipment.

New Poster

Re: Comcast blast not getting full speed

Am I being punished for my previous post? I am now down to the 2MBS up/down speed on Blast service.

http://results.speedtest.comcast.net/result/812302824.png

Contributor

Re: Comcast blast not getting full speed

I feel as if i am in the same boat. I have called and contacted support 3 different times since February third when this issue began with me, and they finally got a tech to my house today to replace the modem and look around in the cable box outside. It has drastically gotten worse, i am between 1-4 mbps for the past 4.5 hours, it is impossible to do anything productive online, and the WORST part is that i am on an ethernet hard wired connection, not even on wifi, i can't imagine how poor my wifi dl/upload would be. 

New Poster

Re: Comcast blast not getting full speed

I signed up to blast and was not happy with my connection. I found out that I had a old 2.0v modem. I switched to a 3.0 version modem, switched my old G wireless router to a TP-link gigabit router with N wireless and now my speeds are 100+ on a wired connection and on the N wireless 85-95mbps. I'm a happy camper!

New Poster

Re: Comcast blast not getting full speed

Here are the results of my tests

 

 

 

 

 

 

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Larry's>tracert www.comcast.net

Tracing route to a1526.dscg.akamai.net [23.62.7.49]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms SepiaSycamore [192.168.1.1]
2 * 9 ms 8 ms c-73-215-132-1.hsd1.nj.comcast.net [73.215.132.1
]
3 * 7 ms 7 ms xe-10-1-0-sur02.union.nj.panjde.comcast.net [68.
86.222.17]
4 9 ms 9 ms 14 ms ae-10-0-sur02.union.nj.panjde.comcast.net [68.85
.35.161]
5 10 ms 9 ms 10 ms ae-3-0-ar03.plainfield.nj.panjde.comcast.net [68
.85.63.161]
6 12 ms 15 ms 11 ms he-2-14-0-0-cr01.newyork.ny.ibone.comcast.net [6
8.86.166.113]
7 20 ms 20 ms 18 ms be-10102-cr02.ashburn.va.ibone.comcast.net [68.8
6.85.25]
8 18 ms 23 ms 19 ms be-10001-cr01.ashburn.va.ibone.comcast.net [68.8
6.85.1]
9 19 ms 18 ms 26 ms be-25-pe06.ashburn.va.ibone.comcast.net [68.86.8
2.166]
10 18 ms * 17 ms 66.208.233.130
11 19 ms 18 ms 20 ms a23-62-7-49.deploy.static.akamaitechnologies.com
[23.62.7.49]

Trace complete.

C:\Users\Larry's>
C:\Users\Larry's>
C:\Users\Larry's>
C:\Users\Larry's>
C:\Users\Larry's>
C:\Users\Larry's>
C:\Users\Larry's>ping -t www.comcast.net

Pinging a1526.dscg.akamai.net [23.62.6.59] with 32 bytes of data&colon;
Reply from 23.62.6.59: bytes=32 time=16ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Request timed out.
Reply from 23.62.6.59: bytes=32 time=39ms TTL=56
Request timed out.
Request timed out.
Reply from 23.62.6.59: bytes=32 time=19ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=16ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=16ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=19ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Request timed out.
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Request timed out.
Reply from 23.62.6.59: bytes=32 time=19ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=16ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=19ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=24ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=20ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Request timed out.
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Request timed out.
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=16ms TTL=56
Reply from 23.62.6.59: bytes=32 time=28ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=17ms TTL=56
Reply from 23.62.6.59: bytes=32 time=35ms TTL=56
Reply from 23.62.6.59: bytes=32 time=18ms TTL=56

Ping statistics for 23.62.6.59:
Packets: Sent = 64, Received = 57, Lost = 7 (10% loss),
Approximate round trip times in milli-seconds:
Minimum = 16ms, Maximum = 39ms, Average = 18ms
Control-C
^C
C:\Users\Larry's>
C:\Users\Larry's>

 

New Poster

Re: Comcast blast not getting full speed

Romina was very polite.  The problem was more in the script that she clearly had to follow.  I was not happy because my speeds are not as fast as they should be.  Romina kept instructing me to use one particular site, www.speedtest.net, to check the speed.  This ONE site reported that my download speed was 121.13 Mbps.  But SEVERAL other sites disconfirmed this result.  www.bandwidthplace.com: 9.6Mbps.  http://en.utrace.de/speedtest.php: 4.68 Mbps.  whatismyip.com: 39.09 Mbps.  So I suggested that Romina propose a speed testing website to use.  She said that "We only use speedtest.net."  Then she wanted to send a technician to my house.  SO many other people are reporting exactly the same issue as I am: just look at http://forums.comcast.com/t5/Basic-Internet-Connectivity-And/Comcast-blast-not-getting-full-speed/td... Those customers' complaints are RECENT.  

In short, I really did not like the fact that the ONE speedtest website Romina was willing to have me use gave a very high speed reading, while THREE other speed test websites gave far lower readings.  And then, when I ask the representative to propose another speed test website, she replies that Comcast only uses the speed test website that gives abnormally high results.  It seems dishonest, frankly.

Yours very truly,
[redacted]

END

Contributor

Re: Comcast blast not getting full speed

I have to tell you that speedtest.net and testmy.net are pretty much the most accurate speed test sites out there.The www.bandwidthplace.com: show download speeds that are way slow and upload speeds too fast. and also testmy.net doesn't  use flash or anything to kinda skew your results just set the server up first. Also it shows the quality and stability in your connection to stream data without pauses.

Contributor

Re: Comcast blast not getting full speed

And basically speedtest.net and xfinity speed site is the same with exception of a couple servers but just stick with speedtest.net or testmy.net...............Don't fully trust xfinity's site.

 

New Poster

Re: Comcast blast not getting full speed

I'm having significant problems in the DC area...

 

My internet connection has been dropped at least three times this morning, and when I am connected, many websites are loading very slowly.  

 

A nationwide "connection map" for Comcast shows that the DC and Philadlephia areas are having connection problems.  I hope Comcast is working to correct the problems.

New Poster

Re: Comcast blast not getting full speed

I have had the same equipment for years now with no changes in wiring, electronics, etc. IMHO - We are "re-provisioned" every month or so until we call and complain about the lack of speed. At which time they put us back on a faster route. If you don't complain, they get money for speeds not being delivered. It has been two months since I called and I am back down to 25Mbps, down from the 105Mbps I am paying them for. Funny how within 5 minutes of a human picking up I am back at 105. I have tried power cycling all equipment. It always is taken care of on the phone and without dispatch needed. - I suggest you CALL COMCAST Customer Service. Regularly.