Community Forum

Android Device Issues

New Poster

Android Device Issues

Our X1 system was installed yesterday (3/4/15), and everything is working perfectly! Except one thing...

 

The WiFi conection to our Android devices (Nexus 5, Nexus 7 1st gen., and Nexus 10) isn't working properly. We can connect them to the network without an issue, but the internet is slower than you could ever imagine. All of our PCs work fine and the interenet speeds are faster than ever, but not for the android devices. If I attempt to load a web page on my nexus 5, it will take a good five minutes, but if I disconnect from the network and simply use my LTE connection, there are no problems. Also, all three android devices worked fine before the X1 system was installed.  

 

Does anyone have any suggestions? Considering our two tablets are WiFi only, this issue has basically deemed them useless.

 

Thanks

New Poster

Android Device Issues

Our X1 system was installed yesterday (3/4/15), and everything is working perfectly! Except one thing...

 

The WiFi conection to our Android devices (Nexus 5, Nexus 7 1st gen., and Nexus 10) isn't working properly. We can connect them to the network without an issue, but the internet is slower than you could ever imagine. All of our PCs work fine and the interenet speeds are faster than ever, but not for the android devices. If I attempt to load a web page on my nexus 5, it will take a good five minutes, but if I disconnect from the network and simply use my LTE connection, there are no problems. Also, all three android devices worked fine before the X1 system was installed.  

 

Does anyone have any suggestions? Considering our two tablets are WiFi only, this issue has basically deemed them useless.

 

Thanks

Expert

Re: Android Device Issues


Detoni12 wrote:

Our X1 system was installed yesterday (3/4/15), and everything is working perfectly! Except one thing...

 

The WiFi conection to our Android devices (Nexus 5, Nexus 7 1st gen., and Nexus 10) isn't working properly. We can connect them to the network without an issue, but the internet is slower than you could ever imagine. All of our PCs work fine and the interenet speeds are faster than ever, but not for the android devices. If I attempt to load a web page on my nexus 5, it will take a good five minutes, but if I disconnect from the network and simply use my LTE connection, there are no problems. Also, all three android devices worked fine before the X1 system was installed.  

 

Does anyone have any suggestions? Considering our two tablets are WiFi only, this issue has basically deemed them useless.

 

Thanks


you should call 800-comcast to schedule a tech to resolve (assuming your wifi router is supplied by comcast). You didn't say you had anything on wired internet to test your connection.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
Contributor

Re: Android Device Issues

Very strange.  I have a hard time believing it is related to them being android devices especially since they are all newer ones at that.  I have both a Nexus 7 and LG G3 phone and both experience pretty much the same speeds as iPhones, Mac laptops, and iPads we use at home.  A few things you might try.  First have you run any speedtests on the network just to see what the speed is?  And I am assuming the laptops you mention are being connected wirelessly as well so it is not a problem with wifi?  And lastly are you using all Comcast equipment?  In other words one of there combo modem routers or do you have your own router?

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

Hi everyone,

 

I see there has not been any activity on this thread in some time but I have just recently run into this same problem.

 

Setup

 

I have a Verizon HTC One (M7 Android 4.4.3) and a Samsung Galaxy (S4 Android 4.4.2). I have had both phones nearly 2 years with Comcast Xfinity cable modem/router for nearly 1 year. I have not had a single problem with the Wi-Fi at home on any device until just this week after returning from a business trip. On this business trip, I did use the phone in Airplane Mode, as I have done this dozens of times previously on other business trips (US domestic and International), phone Wi-Fi worked everywhere just fine but not when I got home.

 

Issue

 

Google (including Google Voice, Gmail, Google+ and Search App) and Facebook ONLY load extremely slowly. They will eventually load but at an ultimate snails pace. I can no longer use the voice search feature, Gmail e-mail does not automatically sync (manual only since I'm sure the auto sync times out) and Facebook updates but no profile pictures, albums, etc. YouTube, Instagram, Yelp, everything else works except Google and Facebook. My personal and work laptops both work fine on the Xfinity Wi-Fi connection and even all the web-based versions of Facebook, Gmail, Google+, etc work fine on Chrome on my HTC One and Samsung Galaxy S4.

 

As soon as I turn off Wi-Fi and jump on my Verizon 4G connection (which is so awesome btw), everything auto syncs instantly, e-mails are flying, Facebook notifications are dinging... You get the picture.

 

Then when I switch to another Wi-Fi connection, everything works fine! Google Voice, Gmail, Search App, Facebook all work fine on OTHER WI-FI CONNECTIONS. It is almost like my home Xfinity router is blocking/throttling these apps all of a sudden.

 

Troubleshooting

 

I have tried setting them both in Airplane mode and off again. Rebooting multiple times. Turning the phones off, rebooting the Xfinity modem/router then powering on the phones, still no luck. Tried wiping the app data caches and data, uninstalling them and re-installing them completely and no luck. I'm not quite sure how the app communicates differently than the web-based version over the same Wi-Fi connection but the evidence is there.

 

My last troubleshooting step was going to be factory resetting the phones but I'm thoroughly convinced that there is something going on with how Comcast is filtering the app connection over the Wi-Fi. I may try adding port forwarding addresses but I should not have to do this to get everything working again. I may also purchase a new modem and router because I would like IEEE 802.11ac support at some point in the future but that is another discussion.

 

Anybody have any suggestions?

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

I have the exact problem with my galaxy S5.   Interestingly enough, it works fine on my Comcast Xfinity WiFi at my office.  But at home, my phone and tablet a S L O W.   Disconnect WiFi and connect to Sprint cellular and lighting fast.  

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

Add me to the list,.......started having problems in February as friends with Android would sometimes say they're having problems with app like instagram and FB. I have a HTC M8 and iPhone5, but never noticed until a week ago.

 

Long story short,...I immediately suspected an IP conflict or DNS issue,...so I removed all connected devices and changed DNS to no avail. Just this morning I woke up and thought to (bridge) the Xfinity router and fire up my NetGear,..............sure enough my M8 started downloading as expected with FB. So this weekend, I'm going to buy a nice AC router to replace that N Netgear and call it a night!

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

I'm having the same exact problem.  Wifi works great on my laptop, blueray player and IPAD, but will not work on my Samsung S4 Android.

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

Same problem here for me on my LG g3 use to work fine then all of a sudden next to no internet instagram nothing loads until I switch off of wifi

Frequent Visitor

Re: Xfinity Wireless very slow on mobile devices only.

 I'm seeing the same problem with a Nexus 7 tablet.  It started a couple weeks ago. I was hoping to find a solution here...

Regular Visitor

Re: connectivity to samsumg s5 with new xfinity wireless gateway1

Mine is doing the same as well.  I have three S5 phones on my account and all three worked fine until two of them got the 5.0 (lollipop) uodate.  Those two are having issues with loading any web access.  Update has a glitch that is killing the communication with router.   

Problem Solver

Re: connectivity to samsumg s5 with new xfinity wireless gateway1

I would also make sure the wifi encryption is set to AES.

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

Same issue.  Note 4, Tab S and HTC one will show as connected to the home WIFI, but will not load non-google webpages - google is the only site that works quickly.  I do a google search and the results appear at normal speed.  However, if I click a link to a result, or enter a non-google URL directly into any of the mobile browsers, the page loads incredibly slowly (minutes).  Strangely enough, the laptop and PS4 connect to the WIFI just fine with no speed issues, and the mobile devices connect to other WIFI networks just fine (work network is Comcast also and I have no problems connecting the devices there).  I've swapped my old modem out with a new one, and did a system restore on the tablet, and nothing seems to work.  Worked fine last week....  The Comcast reps keep telling me to call the device manufacturer, but since they can all connect to other WIFI networks, I doubt they can do anything to help.  Have a tech coming Thursday.  Maybe they'll have some insight.

New Poster

Connecting S6 To Internet with Comcast modem

I have a Samsung Galaxy S6 and cannot get it to connect to internet with my Comcast modem, my other devices are ok. I have no issue with other providers modems. Any ideas how to fix so I connect via this modem?
New Poster

Re: connectivity to samsumg s5 with new xfinity wireless gateway1

Yup, having the same problem here.  It was suggested to me that disabling IPv6 would work, it didn't.  Next thing to try is an older router.  

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

I HAVE FOUND A SOLUTION. Well, at least for me out worked. I was having the same issue where all the devices surfed the Internet and apps perfect minus my android phones.

-log into your modem/router and change the dhcp ip address scheme from 10.0.0.1 to 192.168.1.1
-reboot modem/router
-send me a cheer if it works for you

***android seriously needs to fix that in the next update
Frequent Visitor

Re: Xfinity Wireless very slow on mobile devices only.

Thanks, sincerely, for giving me something to try--but it didn't help...

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

My Note4 and Xperia z2 tablet works flawlessly with my office wifi, the prblem is only with my comcast wifi at home. So it looks like ths issue is with the combination of andriod and comcast.

Regular Visitor

Re: Xfinity Wireless very slow on mobile devices only.

^Yeah all other wifi worked fine. The problem for me was the wifi built into the gateway (TG862G).

 

May 1st the outage map showed a lot of the east coast was down, internet was down then the tv's went off for an hour then everything came on and the problem started. Comcast did something.

 

It would take a couple minutes to connect to a site then load slowly.

 

So I put the TG862G in bridge mode and connected an old belkin router. Problem solved.

 

My best guess is they pushed a new firmware and it broke the wifi for some devices.

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

I had similar issue and got it resolved after going through this blog and reconfiguring my modem. Follow this blog for steps http://nerdyheaven.blogspot.com/ 

New Poster

Re: Xfinity Wireless very slow on mobile devices only.

Just fixed this problem by connecting to the new public xfinity signal broadcasting from my modem on the same channel as my private wifi no matter which channel I use. Presto, went from kbs to Mbs, back to normal. I think it is pretty messed up that they have essentially forced me to use this instead of what I pay them for. I even tried unsuccessfully to disable that xfinity wifi yesterday. It just kept saying error try again whenever I tried to disable it. Is this even legal for them to do?
Frequent Visitor

Re: Android Device Issues

I am having the exact same problem. I have an HTC One M8 and an Arris XB3 gateway. Everything was working fine until last week. Our internet went down and I am assuming the gateway downloaded a firmware update. Ever since it has come back up I can not use the WiFi on my phone, it is way too slow. If I go anywhere else and use WiFi it works perfectly, just not at home. My wife's phone which is an HTC One M7 does work but mine does not. Her's is on android 4.4 and mine is on 5.0.2. I am guessing it is some kind of software conflict.

 

I checked the setting on my gateway and for some reason my phone is assigned 7 different IPv6 addresses. I think that this is the problem but have no idea why it is occurring or how to fix it.

 

I was able to temporarily fix the problem by downloading the app DNSet from the Google Play store. The WiFi now works on my phone but I should not have to download an app to get my WiFi that I pay for to work.

New Poster

Re: Connecting S6 To Internet with Comcast modem

I am having the exact same problem, internet works fine everywhere but with my home comcast modem. 

New Poster

Galaxy 5 WIFI Slow on Comcast

Why, when connected to the Comcast wifi, my mobile connection speed is so slow at home. both of my Verizon cells (Galaxy S5) have same results but when I am on another wifi or the Verizon network its instant access. I tried everything listed on different foums like resetting cable modem, changing the address and the chanels etc... My son has Sprint and it seems to work fine. Im not giving up Verizon. is it the modem? 

New Poster

Re: Galaxy 5 WIFI Slow on Comcast

Having the same problem my S6 edge works fine on wifi everywhere except at home with comcast modem

Frequent Visitor

Re: Android Device Issues

I am fairly certain it is a problem with the firmware for the XB3 gateway. I had Android lollipop on my phone for weeks and WiFi worked fine. Then one night after my gateway firmware updated my WiFi stopped working immediately after my router restarted.
Regular Visitor

Re: Xfinity Wireless very slow on mobile devices only.

I had same problem. Now problem solved. Download DNSet by Marco Gamero from play store. After install check the box for Auto Start and click the start button. Now all of my apps to include Facebook load quickly on my Xfinity WiFi.

Frequent Visitor

Re: Android Device Issues

Thank you--DNSset sure did the trick. Is there any downside with using this?
New Poster

Galaxy S5 wi-fi problems after lollipop update

I'm hoping someone can help me out.  On Saturday night, I was forced to update my Galaxy S5 to the lollipop android OS.  Immediately following the update, my phone began taking an EXTREMELY long time to update any apps or access a website.  If I flip the wi-fi off and use cellular data, everything runs quickly as expected.  Today, on my work wi-fi, all apps work fine.  

 

I have the Comcast provided Arris modem/router combo and the 105MBps internet service.  

 

All other connected devices work fine (iPhone, Windows 7 laptop, Win 7 desktop, iPad2) and have speedy download rates per speedtest app (100+ download/30 upload).  I have gotten the speedtest app to work once on my S5 and I got the same 100+ download speed.  Most of the time, the speedtest app just spins and spins.  

 

I cleared my cache partition on the phone.  That made no difference.

 

I got so desperate that I did a factory reset on phone.  That made no difference.

 

I contacted Samsung and they said there's no known issue and blamed my router/modem.

 

This issue started immediately when I updated the OS.  So there's something between this lollipop OS and my Arris modem/router.  

 

Does anyone have any advice for me?  Oh, I have reset the modem too.  I'm losing my mind....

New Poster

Re: Galaxy S5 wi-fi problems after lollipop update

I have a Galaxy S5, and as all of you have seen first hand, after Lollipop the WiFi sucks. I have cleared cache, factory reset my phone, even got a replacement phone, and had my router swapped. I installed DNSset as mentioned earlier and it worked. Everything is working well. I'll be honest, not sure about the downside of using this app. Any info would be appreciated until a true fix is implemented.

Expert

Re: Galaxy S5 wi-fi problems after lollipop update


daffyduck1970 wrote:

I have a Galaxy S5, and as all of you have seen first hand, after Lollipop the WiFi sucks. I have cleared cache, factory reset my phone, even got a replacement phone, and had my router swapped. I installed DNSset as mentioned earlier and it worked. Everything is working well. I'll be honest, not sure about the downside of using this app. Any info would be appreciated until a true fix is implemented.


a few posts above yours seem to point out it is some kind of dns issue that an app DNSset solves.

 

https://developers.google.com/speed/public-dns/  is free (8.8.8.8 and 8.8.4.4) if you can change it yourself else use the free app to change.

 

I don't have an android device but i'm guessing it has to do with comcast's IPV6 (a good thing) network being used by the android system incorrectly..


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here(updated).
New Poster

Re: Galaxy S5 wi-fi problems after lollipop update

I'm hesitant to use the app because I don't have enough info on exactly what it's accessing on my phone.  Does anyone know?

 

Unfortunately, the Comcast issued Arris modem does NOT allow you to change the DNS config to point to 8.8.8.8 and 8.8.4.4.  Once I get home and back on my wifi, I'm going to try to access a couple sites with their IP rather than their site name.  If that works, then I'll know with 100% certainty that it is a Comcast DNS issue and I guess proceed from there.  

 

Does anyone from Comcast know if those settings can be changed on the modem if I call in and speak to a tech?

Frequent Visitor
New Poster

android devices slow

Recently installed Arris TG862G Modem/Router, connection speeds were fine on Android devices intially. Last night all devices slowed to a crawl. Other wireless connections (Laptops) are fine. Rebooted TG862G and devices , no resolution. Any ideas?

Valued Contributor

Re: android devices slow

Seems to be due to a current issue with a number of Comcast wireless gateways:

 

Comcast’s wireless gateways don’t play nice with Android 5.0 Lollipop, but Google’s on the case
By Quentyn Kennemer, Phandroid - May 13, 2015

http://phandroid.com/2015/05/13/comcast-wireless-gateway-lollipop-bug/

 


A nasty issue with Comcast-bred wireless gateways has spawned for anyone using Android 5.0 Lollipop. According to sources of Phandroid’s familiar with the matter, the bug makes general browsing and download speeds slow to a crawl when an Android 5.0+ device is used over WiFi with a number of Comcast wireless gateways, including (but possibly not limited to):

• Cisco XB3939
• Cisco XB3941
• Arris 852
• Arris 862
• Technicolor 8305c
• SMCD3GNV

So what’s causing the issue? The exact problem is unknown, but we know it only affects customers when they try to use an Android 5.0 or higher device with Comcast gateways that use IPV6. ...

 

Regular Visitor

Re: android devices slow

The first poster in this older thread had the same problem and he had Android 4.4, not 5.0 ...

http://forums.xfinity.com/t5/Home-Networking-Router-WiFi/Xfinity-Wireless-very-slow-on-mobile-device...

 

For me the speed problem started exactly when we switched to the new combination router/modem. Speed was fine before. Now it's fine on PC, but horrible on my phone. I have a Sprint LG G2, Android version 5.0.2. 

Gold Problem Solver

Re: android devices slow


ellig wrote:

The first poster in this older thread had the same problem and he had Android 4.4, not 5.0 ...

http://forums.xfinity.com/t5/Home-Networking-Router-WiFi/Xfinity-Wireless-very-slow-on-mobile-device...

 

For me the speed problem started exactly when we switched to the new combination router/modem. Speed was fine before. Now it's fine on PC, but horrible on my phone. I have a Sprint LG G2, Android version 5.0.2. 


One of the first things I did with my TG862G was to purchase a higher quality router and BRIDGE it to the TG862G.... have had no issues with Android from 4.2 to 5.01 with any devices...

 

-=Ray=-

Regular Visitor

Re: android devices slow

Thanks for the suggestion, geek46. I'm hesitant to buy a router because I'd be peeved if Comcast then resolved the issue.

 

I'm new to these boards. Does Comcast ever answer questions in this forum, or is there a different forum where they answer questions?

 

Also, saw this about the DNSet app, which was a little concerning - https://www.reddit.com/r/LGG3/comments/3636e4/psa_dnset_app_that_claims_to_fix_wifidns_issues/

Gold Problem Solver

Re: android devices slow


ellig wrote:

Thanks for the suggestion, geek46. I'm hesitant to buy a router because I'd be peeved if Comcast then resolved the issue.

 

I'm new to these boards. Does Comcast ever answer questions in this forum, or is there a different forum where they answer questions?

 

Also, saw this about the DNSet app, which was a little concerning - https://www.reddit.com/r/LGG3/comments/3636e4/psa_dnset_app_that_claims_to_fix_wifidns_issues/


Nothing will change the poor range and signal that Comcast devices have inherit in them.... only by purchasing a high quality router will make your signal reach further, and better....

 

Nope... not really...  if you're lucky you can find a helpful Comcast Type and send them a PM ( private message ) and if you're extremely lucky, they will answer and help you out...

 

These forums are basically user-to-user help areas...  the long-time forum members volunteer their time to help out user with issues as most have been there and done that with Comcast services over the years...

 

I am very hesitant to use that APP....  I have had no need to do so ever....  Sorry, but I would not look for that to be your answer.

 

-=Ray=-

Frequent Visitor

Re: Android Device Issues

My solution was to switch to Fios. Everything is working fine now!
Regular Visitor

Re: Android Device Issues

Wow, it's fixed. I didn't change a thing, just woke up this morning and internet is now quite fast. Yay!

Frequent Visitor

Re: android devices slow

My Comcast wireless service failed this morning.  I just spent two hours on a chat session with Comcast getting it fixed.

 

Although wireless was down, I was able to connect using an Ethernet cable to my Comcast tc8305c modem.  Very strange.

 

Wireless problem seemed to be an issue with DNS, although it is possible that there was no connectivity at all.

 

The Comcast tech refreshed my connection.  That allowed my Windows devices to connect to wireless again, but two Android phones still were not working.  I had to reboot my Android 5.0.1 phone to get it working on the wireless again.  I have yet to try rebooting the other Android phone to see if it will work now.

 

In the process of trouble shooting the problem, I noted that DHCP is giving my Windows PC IPV6 (as well as IPV4) addresses:

 

DNS Servers . . . . . . : 2001:558:feed::2
                                    2001:558:feed::1
                                    75.75.76.76
                                    75.75.75.75

 

It is at least possible that my problems occurred because Comcast cut over to IPV6 in my area this morning.

New Poster

Re: Android Device Issues

This a known issue that comcast is currently trying to find a fix for. Swapping modems is a temporary fix but issue will reappear.
Diamond Problem Solver

Re: Android Device Issues

Year old thread closed.