Community Forum

A Few Different Things

New Poster

A Few Different Things

We have some issues that have been ongoing, and some that recently started.

1. When logging into one of my favorites, it "gets stuck". It is a bank site, and it hangs so I cannot do anything. I get a message "----------- is not responding"..... "Recover webpage". This is very frustrating and time consuming.

2. Using Craig's List- you could click on "Show phone number" and then select "Reply by email or phone". It now comes up with "An error has occcured".

3. Lastly, we are part of a group email, a Listserv. These Listserv emails have not been coming through to us. Very disturbing.

Comcast is not a cheap service, and we expect better from you.

Expert

Re: A Few Different Things


@suzydanb wrote:

We have some issues that have been ongoing, and some that recently started.

1. When logging into one of my favorites, it "gets stuck". It is a bank site, and it hangs so I cannot do anything. I get a message "----------- is not responding"..... "Recover webpage". This is very frustrating and time consuming.

2. Using Craig's List- you could click on "Show phone number" and then select "Reply by email or phone". It now comes up with "An error has occcured".

3. Lastly, we are part of a group email, a Listserv. These Listserv emails have not been coming through to us. Very disturbing.

Comcast is not a cheap service, and we expect better from you.


 

Do these issues replicate on other browsers than the one you're using?  


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: A Few Different Things

Hello suzydanb. Welcome to the Xfinity Forums and thank you for creating your first post. We're sorry your having troubles with your service. It is very important to know if you experience these same symptoms on another web browser, as 'darkangelic' had asked. Are you cable to confirm this?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: A Few Different Things

I'm not sure, but don't think we have the same problem with other web browsers. Every so often we get the message "the internet explorer has stopped working". Does that mean anything?

Official Employee

Re: A Few Different Things

If you are only experiencing these issues on the one web browser, this is a good sign your internet provider is not the root cause of your problems. To attempt to fix the issues, I would either switch to a new more powerful trusted web browser, or troubleshoot your existing browser. 

 

Two things to make sure of with your existing browser:

  • Try to update the browser and ensure you have to most up to date version. 
  • Completely clear the cache and cookies history. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Expert

Re: A Few Different Things

See:

 

https://forums.xfinity.com/t5/Internet/ANSWERED-How-to-clear-your-Internet-browser-history/ta-p/2967...


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!