Community Forum

1 Gig Xfinity Internet Service Installed, but getting slow internet speeds.

New Poster

1 Gig Xfinity Internet Service Installed, but getting slow internet speeds.

     About two weeks ago, I upgraded to the Gigabyte service offered by Xfinity.  However, after the installation, I tested my download and upload speeds.  I was getting approximately 300 Mbps (Down) and 40 Mbps (Up).  

 

     So, I called Xfinity, and they sent numerous updates and bootfiles to my Xfinity Modem / Router.  I even reset the modem/router several times in efforts to resolve my speed issues.  After doing this, they sent out an Xfinity Technican on three different occasions.  All the Xfinity Technicians could do, was hook up there testing equipment, and continued to show me that the download speeds were 998 Mbps (Down) and 40 (Up).  This test was conducted by the Xfinity Technicain, with there testing equipment.  

 

     I have my desktop hardwired with Cat 6 ethernet cable direct to the Xfinity Modem/Router with nothing else attached, and was still receiving very slow internet speeds.  I tested a total of 15 computers (All hardwired) direct to my Xfinity Router/Modem and again, I still am receiveing slow internet speeds.  

 

     After the fourth visit from a Senior Xfinity Technician, he stated that they test the down/up speeds, that they are connecting to a special / dedicated server that gives them the high download / upload speeds.  The technician said, that since I am connecting to a different server, the test can be very low based on how many customers are using the server at any given moment.  

 

     The other issue I have, is that prior to my upgrade to the gig service, I was on the Pro Tier and was getting faters speeds than I am now; I don't understand what is going on.  I have had my Xfinity Modem/Router swapped out on three different occasions, and I am still getting slow internet speeds.  

 

     The lines in and outside of my home have been tested by an Xfinity Technican, and they are reporting that the lines are in excellent shape.  I looked at my downstream channels with the technican, and they are in the correct settings.  

 

     I have hired two local network contractors to research my internet speed issue, and they themselves are stating that in there professional opinion, Comcast is able to say that the customer are able to receive 1 gig speeds because they test off of a special / dedicated server that the customer does not have access to.  

 

     The two contractors hooked up four laptops that had 1gig (Full Duplex) nic cards, and they were recieving the slow internet speeds as well.  The technicans could not give a final determination, other than they said that Comcast if falsley providing test results to the customer, becasue they are from a specialized / dedicated server and that server is not providing true internet speeds. 

 

     I have tried everyhting from under the sun, and no matter what I do, I can not get even close to obtaining 700 to 800 Mbps download speeds.  I have even tried different cable routers that are accepted by Xfinity and several different types of routers in (Bridge Mode).  I am left paying for a service that I am not getting and I don't think that is fair.  

 

     If anyone has any other sugestions, I would love to hear them, as I would like to get what I am paying for.  Thanks everyone.  

Expert

Re: 1 Gig Xfinity Internet Service Installed, but getting slow internet speeds.

@chadlenk0558

I don't know why anyone is telling you that Comcast is testing to special/dedicated servers, that is completely untrue. They test from 22 servers that are available to anyone using speeedtest.net. 

 

Start here: troubleshooting guide.  Please post your equipment details (make/model of your modem/gateway/router) and a screenshot of your signal levels and your error/event log. Thank you!




I am a volunteer Expert/Moderator, not an employee.