Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,858,838

members

909

online

29,042

topics

Top

xFi never loads devices

ANSWERED
New Poster

xFi never loads devices

Just got xFi up and working today, but the app continues to state it is loading devices for the first time after waiting hours... Help please!
Accepted Solution

Re: xFi never loads devices

Restarting my router appears to have fixed things.
View answer in context
Screenshot_20180210-182019.png
Service Expert

Re: xFi never loads devices

Sometimes ending the program and restarting it will clear up some issues.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Highlighted
New Poster

Re: xFi never loads devices

Restarting my router appears to have fixed things.
Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 2 replies
  • 297 views
  • 0 kudos
  • 2 in conversation