Community Forum

xFi app not working

New Poster

xFi app not working

My xFi app was working before. Now it says settings currently unavailable and I am unable to use that app.
Silver Problem Solver

Re: xFi app not working

How close are you to your wifi - are you not at your residence?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Official Employee

Re: xFi app not working

Are you still experiencing this problem? The "Settings Currently Unavailable" message in xFi typically means that your Gateway device has gone offline. Once you can confirm it's back online, try force closing out of the app and re-launching to see if the app responds properly. 

If you're internet service is working fine, but you continue to receive this message, please let us know and we'd be happy to look into it. 

 

Frequent Visitor

Re: xFi app not working

I also am unable to get xfi to work. Despite the Xfnity Gateway being online, and force-quitting and restarting the app.  All I get is "Settings currently unavaible".

New Poster

Re: xFi app not working

I keep getting this too despite gateway being up and reinstalling the app
New Poster

Re: xFi app not working

Hi! Our cable/internet/WiFi is working just fine but my xFi app is all of a sudden telling me: “settings currently unavailable”, and I am at home. How do I fix this?
Silver Problem Solver

Re: xFi app not working


@Ashley7103 wrote:
Hi! Our cable/internet/WiFi is working just fine but my xFi app is all of a sudden telling me: “settings currently unavailable”, and I am at home. How do I fix this?

Try reinstalling the app.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
New Poster

Re: xFi app not working

Same problem here. Just got the gateway. Both app and web page show same error. Reinstalling app didn't work. I have yet to connect to the xfi interface. Internet is fine, I just can't look at settings for router or gateway.
Silver Problem Solver

Re: xFi app not working


@JDW24 wrote:
Same problem here. Just got the gateway. Both app and web page show same error. Reinstalling app didn't work. I have yet to connect to the xfi interface. Internet is fine, I just can't look at settings for router or gateway.

Can you use the web interface?

https://internet.xfinity.com/


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
New Poster

Re: xFi app not working

No, the web interface doesn't work either. I also tried connecting through the TV, and followed the restart instructions. No dice.
Silver Problem Solver

Re: xFi app not working

It sounds like you don't have xFi.

https://www.xfinity.com/support/articles/xfinity-xfi-overview


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
New Poster

Re: xFi app not working

Chatted with Comcast. They asked me to login as admin. I was at work and couldn't. Then when I arrived home, my Xfi was working. I'd suggest all of you that get the cannot connect error to contact Comcast, preferably at home. I'm guessing it's a server side issue.
Expert

Re: xFi app not working

My app doesn’t work despite reinstalling the app. Web interface is fine. Get following error on app.

CDB68E4E-02E8-4EE1-9321-5C7335686680.jpegxFi app not working

 

Silver Problem Solver

Re: xFi app not working


@jweaver0312 wrote:

My app doesn’t work despite reinstalling the app. Web interface is fine. Get following error on app.

CDB68E4E-02E8-4EE1-9321-5C7335686680.jpegxFi app not working

 


What smart device are you using?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Expert

Re: xFi app not working

iPhone but the app seems to be working at the moment.
New Poster

Re: xFi app not working

Just downloaded the XFi app 4 days ago. The first 2 days app worked. Last two days, app has been unavailable. WiFi is working for all the devices in home.
Silver Problem Solver

Re: xFi app not working

Check to see if there is an update to the xFi app.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Expert

Re: xFi app not working

App stopped working again. No updates for the app from the App Store.
Current version: 1.9.0
Highlighted
Silver Problem Solver

Re: xFi app not working


@jweaver0312 wrote:
App stopped working again. No updates for the app from the App Store.
Current version: 1.9.0

Are you having any issues with your gateway?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Expert

Re: xFi app not working

Other than speed issues that they are working on fixing, no.
Silver Problem Solver

Re: xFi app not working

My app doesn't work whenever I get an interruption on my gateway.  It can last for a few minutes or more.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Expert

Re: xFi app not working


@RobertWy wrote:

My app doesn't work whenever I get an interruption on my gateway.  It can last for a few minutes or more.


Mine has been like it for a few days now.

New Poster

Re: xFi app not working

After an outage I had yesterday my XFi app isn’t connecting. I keep getting the Settings Currently Unavailable message. Can you pleas advise?
New Poster

Re: xFi app not working

I am having this issue as well. Set up the WiFi as directed. I am actually currently on the WiFi typing this. And the app gives me the same message And also says to set up new gateway
Regular Visitor

Re: xFi app not working

App hasn’t really worked in about a week...

i wouldn’t care all that much except I can’t get any notifications about access changes (network traffic or router alterations) and my router has been “altered” several times!

Since I’m still trying to recover my life after the Utopia.com hijack that required factory resetting over a dozen devices that were attached to my previous 4 gateways...

I’d hoped to feel confident in connecting my newly scrubbed devices to my new gateway... paranoia/experience had me check the “ admin” page before connecting the first device... “Port Triggering” and “Remote Management” we’re both enabled and IPv4 Security was set to “Low”!

No help/explanation from Tier 2 Support... I resecured... verified... and connected 1st device.

Before connecting 2nd device, IPv6 Security was turned off all together! Also, CM Error Codes were in the hundreds (one was above 1,800)! I’ve only had this gateway since the 11th... Again Support was not helpful and told me to use the xFi app (it doesn’t show this info). Also, the automated phone system will automatically troubleshoot for you and reset your gateway. This will erase all error codes and reset the system so when you do reach a person.... “everything looks fine on our end Smiley Happy

Again, I resecured... verified... and connected 2nd device...

Just checked again before device #3... 

“Parental Controls” are suddenly ON and adding devices to a “Trust this Device” list! The Uncorrectable CM Error Codes are holding at zero but since the system was last reset (3 days, 11 hours),

I have     7,315,195       “Correctable Error Codes”!!!!!

AND... the System Logs shows on two occasions a Teredo Port was opened, mapped and used, the closed and deleted!

Never received a single notice...

New Poster

Re: xFi app not working

XFi works but I can’t get the xFi app to find the gateway
Silver Problem Solver

Re: xFi app not working


@LLac wrote:
XFi works but I can’t get the xFi app to find the gateway

Are you able to find xFi on the web?

https://internet.xfinity.com/

Do you have more than one Comcast userid/passwords?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.