Community Forum

xFi Pods Fast Connection Throughout?!?!

Frequent Visitor

xFi Pods Fast Connection Throughout?!?!

I’ve purchased 6 xFi Pods and the setup was fast and seemless. Through the xFi app it says that they are all connected to my network. My question is, am I suppose receive the sm3 speeds throughout the house using the Pods as if you are close to the WiFi router/modem? Speedtest says I have around 240mbps down and 12 up when close to the router/modem. Are the Pods suppose to expand these same speeds throughout the entire house? Even at the furthest point? I believe at the furthest point I was getting 100mbps down. I’m asking this question because it seems that I am not getting these speeds throughout the house. Is the coverage that much better from before I had them? I guess I was under the impression that the highest speeds would be channeled throughout the house with this mesh system. If anyone can help give me some feedback on your experience and possibly help with some of my questions I would greatly appreciate it! Thanks so much! 

New Poster

Re: xFi Pods Fast Connection Throughout?!?!

Having the same issue here.  And the speed is sporatic.  Sometimes I am down to under 10mbps in places I had 60 or 70 mbps before.

 

I am not satisfied with them.   And the tech service from Xfinity is AWEFUL about the pods.  The reps all say to have 2 networks (5 and 2ghz), but anyone that has set these up knows that is not what the app wants you to do.

 

I am frustated and taking it out on the board today!!  I have been dealing with this since the end of December.  Numerous (15 to 20) call, open tickets, 2 tech vists, new gateway, and still no answers.   Having to reset the gateway 4 to 5 times a week is unaccepatable.....

Highlighted
Silver Problem Solver

Re: xFi Pods Fast Connection Throughout?!?!


wrote:

Having the same issue here.  And the speed is sporatic.  Sometimes I am down to under 10mbps in places I had 60 or 70 mbps before.

 

I am not satisfied with them.   And the tech service from Xfinity is AWEFUL about the pods.  The reps all say to have 2 networks (5 and 2ghz), but anyone that has set these up knows that is not what the app wants you to do.

 

I am frustated and taking it out on the board today!!  I have been dealing with this since the end of December.  Numerous (15 to 20) call, open tickets, 2 tech vists, new gateway, and still no answers.   Having to reset the gateway 4 to 5 times a week is unaccepatable.....


I don't have the pods but I do have the Orbi mesh devices; they also show low download speeds on speedtest.net when I am in certain areas of my residence.  My feeling is that it is normal for my network.  If I am sitting next to my Orbi router it shows a download speed that matches my speed tier.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Official Employee

Re: xFi Pods Fast Connection Throughout?!?!

PearlJam, thanks for posting and great question. The xFi Pods speeds apply just as WiFi speed applies when you aren't connected directly to your modem: You will see faster speeds when connected directly to your modem via ethernet cable. All other WiFi connections via WiFi or router (in this case, the pods) will see varying speeds. For your speed tier, you will have speeds up to a certain mbps when connected directly and otherwise.

 

WiFi Signal degradation is influenced by many factors including signal interference (walls, microwaves, etc), distance from the modem itself, and device capabilities. 

 

KenF

Silver Problem Solver

Re: xFi Pods Fast Connection Throughout?!?!


@Antndeb wrote:

Having the same issue here.  And the speed is sporatic.  Sometimes I am down to under 10mbps in places I had 60 or 70 mbps before.

 

I am not satisfied with them.   And the tech service from Xfinity is AWEFUL about the pods.  The reps all say to have 2 networks (5 and 2ghz), but anyone that has set these up knows that is not what the app wants you to do.

 

I am frustated and taking it out on the board today!!  I have been dealing with this since the end of December.  Numerous (15 to 20) call, open tickets, 2 tech vists, new gateway, and still no answers.   Having to reset the gateway 4 to 5 times a week is unaccepatable.....


I just checked speedtest.net again; 299 down sitting next to the Orbi that is ethernet-connected to my XB3.  That is with my iPhone7 which is obviously wifi to the Orbi.  

My home has always had terrible wifi and I've tried many different configurations; I even ran an ethernet connection all the way from one end of my home to the other trying to get a better connection; I bought a Nighthawk at the end and still couldn't get a decent wifi connection.

If I lived in the market where the xFi pods were available. I would buy a six-pack and plug them into every room and hope that fixed the issue.

 

But my experience with Orbi is telling me that even with a mesh network, there are dead spots that can't get a decent wifi connection.

 

I have four adult children that visit often and they bring their wifi devices and say they can't get a decent connection.

And it is very difficult to use my Chromecast Ultra.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Frequent Visitor

Re: xFi Pods Fast Connection Throughout?!?!

I’ve got the normal Plume Pods rather than the Comcast version but AFAIK, they are architecturally the same product. I’ve never done better than about 120Mbps when the pods are using wireless backhaul (the inter-pod connection). When I use wired backhaul, speeds jump to 240-325Mpbs. That’s measured using iperf3.

 

Wireless performance is effected by a huge number of factors so every situation is unique and almost impossibly complex to analyze without specialized expertise and knowledge. To a large extent, customers and the Comcast techs are largely just stumbling around in the dark trying to guess at the best placements for the pods and if the results observed are “as expected” or show a problem. I know that when I did my initial configuration, I ended up sending a layout for my house to Plume tech support and they worked with me to fine tune the pod placements based on the strength of the intro-pod connections. I have no idea if a Comcast customer to tech can get access to the same kind of support.

 

The “rules of thumb” I’ve developed over the past 9 months of using Plume are:

 

1. Whenever possible, use wired rather than wireless backhaul with Gigabit Ethernet, MoCA 2.0 or better, or Ethernet-over-Powerline (latest gen only) connrctions. That dramatically decreases complexity and increases performance.

 

2. Place the pods in the rooms where you most heavily use WiFi. Ideally, you want a near line of sight connection between the client and the pod.

 

3. Try to have no more than 2 walls and 40’ between two pods that are using wireless backhaul. As soon as the backhaul has to switch to 2.4, performance is compromised. RF obstructions (think rebar in concrete walls, HVAC ducts and equipment, larger mirrors) are big issues.

 

4. Don’t obsess about benchmarked performance. The reality is that a 80-100Mps stable, low-latency connection for all your wireless clients is plenty of performance for almost all devices all the time.

Frequent Visitor

Re: xFi Pods Fast Connection Throughout?!?!

Forgot one other tip. If you are experimenting with different placements using wireless backhaul, you have to wait for the great optimizer in the sky to run before testing it. You have to wait 24 hours to be sure it ran. I don’t know a way to tell when it last run and the only way I know to force it is by contacting Plume support (don’t know if it’s an option if you are running the Comcast versions).

 

Also, testing any of the mesh systems is a giant PITA as it’s impossible to force the client to use a particular band and access point for a connection. Maybe it’s possible with a few specific devices but I don’t know any way to do it with a macOS/iOS device. Just set it up with a best guess and don’t mess with it unless you encounter a problem with performance being a noticeable problem in some part of the house. Unless you want to become a WiFi engineer in your spare time...

New Poster

Re: xFi Pods Fast Connection Throughout?!?!

Are the xFi pods capable of being configured for wired ethernet backhail, and, if so, what are the required steps.
Silver Problem Solver

Re: xFi Pods Fast Connection Throughout?!?!

Googled.

 

https://www.xfinity.com/support/articles/xfi-pods-faqs

 

"Note: Be sure to plug your Pods into active electrical outlets. Do not connect your Pods directly to your xFi Gateway using the Ethernet port on the bottom of the Pod. The Pods connect wirelessly to the xFi Gateway. You will not be able to activate your Pods if one is connected directly to the Gateway."


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Frequent Visitor

Re: xFi Pods Fast Connection Throughout?!?!

I have the PODS, and will be installing them soon around a nasty multilevel staggeredlevel house.

I also have the NetGear WiFi Analytics [Android] app installed on a smartphone with both 2 and 5 capability, and the app can be set to choose either, both, or a specific channel.

 

When initially trying placement, would I want to place the first Pod where the signal on both bands is quite high, then start moving outward/upward from there in "baby steps" to places close to that first one and where the signal is currently a bit weak?   

 

 

Roughly how long after initial install should we wait before attempting to tune coverage? 

After any intial placement adjusts, how long should we wait to check strength again before making further adjustments? 

24 hours, or does the mesh adjust itself in a shorter time?

 

Thanks.  

 

 

 

 

 

Tags (1)
Regular Visitor

Re: xFi Pods Fast Connection Throughout?!?!

Have put in my 6 pods - -they are slowly "adjusting" over the last day or so.

I do have ethernet that goes to some of the rooms where there are pods.   Plume lets you use the ethernet to connect to router to improve speed.  For the xfinity pods is just says not to use when intalling.  Can I connect the ethernet once all "installed?"

Official Employee

Re: xFi Pods Fast Connection Throughout?!?!


@rrushakoff wrote:

Have put in my 6 pods - -they are slowly "adjusting" over the last day or so.

I do have ethernet that goes to some of the rooms where there are pods.   Plume lets you use the ethernet to connect to router to improve speed.  For the xfinity pods is just says not to use when intalling.  Can I connect the ethernet once all "installed?"


Hi rrushakoff, 

xFi Pods are currently designed to connect wirelessly to each other and the xFi Gateway, and cannot be connected via Ethernet to each other or the Gateway during or after activation.  Support for Ethernet Backhaul functionality is not currently supported.

New Poster

Re: xFi Pods Fast Connection Throughout?!?!

Upgraded to a new 1GB modem and purchased three pods to help push wirelss to the whole house.  As soon as it merged to 2.4 nothing but problems.  Two wireless satellite boxes stopped working and wireless connectivity dropped for five to ten minutes several times a day.  Tech came out and said that wireless satellite boxes were searching for 5BG signal.  Not sure why, but installing the pods made it impossible to reset the modem to both 2.4 and 5GB even after removing the pods from the system.  Tech resorted to bringing in a new modem.  Returned the pods today.  I cannot recommend these until the 2.4 and 5GB issues are resolved.

Official Employee

Re: xFi Pods Fast Connection Throughout?!?!

Hi cccjc74, 

 

Sorry for the experience you had. Please feel free to reach out in the future if you need assistance.  

New Poster

Re: xFi Pods Fast Connection Throughout?!?!

My xFinity router/modem has been recently updated to support the Gig Speed.  The old equipment broadcasted strong wifi signal upstairs, downstairs and outside.  Unfortunately, the WiFi signal with the new equipment is not as strong.  Signal cuts out in certain parts of the hosue.  An issue I never had with Comcast.  When I spoke with tech, they suggested I purchase a WiFi AC Extender.  I did and now the signal is better, however, the speed is not.  I am experiencing alot of buffering, whereas with the prior equipment, I was not.  I've had another tech come out and replace the equipment but still having the same issue.  It was suggested that I look into purchasing the xFi Pods.  My question are as follows:

  1. Does the pods allow a computer to connect to it via Ethernet Cable?  My son is a gamer and he seems to think connecting directly to the Gateway or the AC Extender helps with lag time.  Not sure how correct this is as I've heard different things from different people, but I don't want to hear about lag time, so if he thinks it helps, so be it.
  2. If the pod does not allow a computer to connect to it via Ethernet Cable, can we still keep our AC Extender in my son's room so he can "connect"?

Thank you for your help.

Silver Problem Solver

Re: xFi Pods Fast Connection Throughout?!?!


@rdrherrera0724 wrote:

My xFinity router/modem has been recently updated to support the Gig Speed.  The old equipment broadcasted strong wifi signal upstairs, downstairs and outside.  Unfortunately, the WiFi signal with the new equipment is not as strong.  Signal cuts out in certain parts of the hosue.  An issue I never had with Comcast.  When I spoke with tech, they suggested I purchase a WiFi AC Extender.  I did and now the signal is better, however, the speed is not.  I am experiencing alot of buffering, whereas with the prior equipment, I was not.  I've had another tech come out and replace the equipment but still having the same issue.  It was suggested that I look into purchasing the xFi Pods.  My question are as follows:

  1. Does the pods allow a computer to connect to it via Ethernet Cable?  My son is a gamer and he seems to think connecting directly to the Gateway or the AC Extender helps with lag time.  Not sure how correct this is as I've heard different things from different people, but I don't want to hear about lag time, so if he thinks it helps, so be it.
  2. If the pod does not allow a computer to connect to it via Ethernet Cable, can we still keep our AC Extender in my son's room so he can "connect"?

Thank you for your help.


1.  No

 

2.  I don't have pods but I suggest you try and see if it works.  You have nothing to lose.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.