Community Forum

xFi Pod Ethernet Connectivity

Regular Visitor

xFi Pod Ethernet Connectivity

Have been using pods successfully for about 4 months. Then on about Sep 25, Ethernet ports on all 3 pods died at the same time.  This would indicate to me that it must have something to do with my gateway.  However, after doing extensive troubleshooting with Comcast, they replaced the pods. Same issue with new pods.  No Ethernet connection. Anyone have any ideas?

Silver Problem Solver

Re: xFi Pod Ethernet Connectivity


@tannercd wrote:

Have been using pods successfully for about 4 months. Then on about Sep 25, Ethernet ports on all 3 pods died at the same time.  This would indicate to me that it must have something to do with my gateway.  However, after doing extensive troubleshooting with Comcast, they replaced the pods. Same issue with new pods.  No Ethernet connection. Anyone have any ideas?


Does the ethernet port work on your XB3/XB6?  You weren't clear.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Regular Visitor

Re: xFi Pod Ethernet Connectivity

Yes, Ethernet ports on XB6 work fine. Ethernet ports on the Pods only are not working. WiFi is working fine. 

Highlighted
Official Employee

Re: xFi Pod Ethernet Connectivity

tannercd - Thanks for reaching out. I apologize for the frustration. I've pulled up your account & started looking into this issue.  Can you provide a little more detail -- What kind of device did you have connected to the Pod?  How were you able to determine that device no longer had connectivity?  


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: xFi Pod Ethernet Connectivity

Hi, Rachel. It’s a garage door opener module. When it stopped working, I plugged it into the other Pod Ethernet ports. None of them worked. Thinking my garage module was bad, ordered a new one. To my surprise, it didn’t work either on any of the Pods. So, plugged directly into an Ethernet port on the modem, and it works perfectly. 

Official Employee

Re: xFi Pod Ethernet Connectivity

tannercd - Thanks for the additional information.  That's helpful!  Curious if you're using an app to control the garage door opener?  Or is it operated using the device itself?  

Have you tried to connect any other devices using the ethernet ports on the Pods?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: xFi Pod Ethernet Connectivity

There is an iOS app. It sends a message to my phone when the garage door opens or closes. Don’t have any other readily accessible Ethernet devices to test. Will try to find another Ethernet device this weekend.