Community Forum

xFi Advanced Security blocks access to plex

Highlighted
Contributor

xFi Advanced Security blocks access to plex

Set up plex on my NAS but the only way to connect from outside of my home connection is to disable my xAS. Anyone know if there is a way to adjust the settings or do i just cancel the service? The error on plex says 

Not available outside your network

Your server is signed in to Plex, but is not reachable from outside your network. Learn more

Highlighted
Official Employee

Re: xFi Advanced Security blocks access to plex

Greetings, serviceman77! I appreciate you taking the time to reach out to us here on the forums. I hope you are having an amazing day. I apologize to hear you are having issues with trying to access your media library through PLEX while outside of your home. Can you please verify you have remote access turned on based on the following article: https://support.plex.tv/articles/200931138-troubleshooting-remote-access/ ?

Can you also check to make sure your reserved IP is matching up to the machine that is running the Plex server? If everything checks out fill free to send me a PM with your first and last name so I may further assist you.

To send me a Private Message, please click my name “ComcastAlly” and click “send a message.”


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: xFi Advanced Security blocks access to plex

I have verified the ip and port. The pm has been sent as well. What I was able to determine is that if I disable the xFi advanced security feature, I am able to connect. Is there a way to change what xAS blocks. I would have thought that a port forward would still work with the security enabled. Thank you again for your time.
Highlighted
Regular Visitor

Re: xFi Advanced Security blocks access to plex

Having the same exact problem here.

Using Plex default 32400 doesn't work

Forwarding Plex to different port doesn't work.

Turn off xfi advance security Plex remote access works.

Highlighted
Official Employee

Re: xFi Advanced Security blocks access to plex

cutty863, when you get the security alert on your xFi App, you should have the option to "ignore" or "allow" for a 30-day timeframe. I do not see a way to extend that timeframe or allow it permanently, but I'll submit your feedback! 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: xFi Advanced Security blocks access to plex

Thank you for you quick reply.  

I'm just a simple man....what I don't understand is why port forwarding doesn't allow Plex to work.  Almost seems that xfi is controlling what it will and won't allow and not end user wishes.

For time being I'm just turning off xfi Advance Security.  Its a simple fix/work around to the problem.  May not be best answer....but it allows Plex remote access  to work.

 

 

Highlighted
Official Employee

Re: xFi Advanced Security blocks access to plex

cutty863, you're very welcome! I'm not sure why port forwarding doesn't resolve the issue, but it definitely sounds like xFi Advanced Security is the feature that's preventing you from being able to access Plex. I've submitted your feedback to hopefully find a fix for this in the future. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!