Community Forum

Xfinity xFi Pods not able to connect

Frequent Visitor

Xfinity xFi Pods not able to connect

I got 3 Xfi Pods yesterday and trying to get them activated. Wasn't able to do the same. Called the support they engaged the tier 2 support but they were also not able to help. 

 

The Xfi App is able to detect the Pod but then it show a message that Sorry couldn't actviate the pod. please connect with Customer care with the Serial number. 

 

I have spend more than 2 hours as of now with Service agent over the phone. NO Results. 

 

Please help 

Official Employee

Re: Xfinity xFi Pods not able to connect

KapilGulati -- Happy to help.  I will need some more information from you. I have sent you a private message. Private messages can be accessed by clicking on the envelope icon in the upper right hand corner of any forums page. Thanks! Rachel 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Xfinity xFi Pods not able to connect

Sent you a PM with the Serial numbers.

Frequent Visitor

Re: Xfinity xFi Pods not able to connect

Now I am able to connect  the PODs but as soon as they came online My TV is not able to connect with the WiFi. And I can confirm it working minutes before PODs came online

Official Employee

Re: Xfinity xFi Pods not able to connect

Thank you for the additional information.  I've received your PM about this issue & will continue to troubleshoot with you there.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Xfinity xFi Pods not able to connect

The pods are a headache. I spent over 2 hours yesterday trying to get them to connect. Never got them to work. Taking them back. It's not worth the headache.
Silver Problem Solver

Re: Xfinity xFi Pods not able to connect


@Willischris01 wrote:
The pods are a headache. I spent over 2 hours yesterday trying to get them to connect. Never got them to work. Taking them back. It's not worth the headache.

There are some other mesh products out there; some are very expensive, but they work if you set them up correctly.

https://www.techradar.com/news/best-wireless-mesh-routers

Some products are actually not mesh, so do your due diligence.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Official Employee

Re: Xfinity xFi Pods not able to connect

Willischris01 - Responded to you via your other comment.  I'm happy to help you onboard the Pods.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!