Community Forum

Xfinity Xfi app not working

New Poster

Xfinity Xfi app not working

I'm having a similar situation that other users have reported. The xfi app isn't working following my installation of a new gateway received from Comcast.
Silver Problem Solver

Re: Xfinity Xfi app not working


pdsmas wrote:
I'm having a similar situation that other users have reported. The xfi app isn't working following my installation of a new gateway received from Comcast.

Does the new gateway appear in My Account?

 

https://customer.xfinity.com/#/services/internet


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
New Poster

Re: Xfinity Xfi app not working

Yes, including two previously used devices that are no longer needed.
Silver Problem Solver

Re: Xfinity Xfi app not working


pdsmas wrote:
Yes, including two previously used devices that are no longer needed.

What are the two devices?  I had some old devices on my account and I called 1800comcast and they were able to remove them.  Maybe they are what is causing your issue.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.
Regular Visitor

Re: Xfinity Xfi app not working

Mine hasn’t worked in over a week. They said they were on it but how can it take this long? Anyone able to get past the whole Upgrade message?
New Poster

Re: Xfinity Xfi app not working

I had to work my way through customer and technical service by phone. It started working while I was talking to them, but they weren't sure why it wasn't before or what exactly they did to fix it.
Official Employee

Re: Xfinity Xfi app not working

Delrayme, I have reached out via private message to troubleshoot this issue further. 

Official Employee

Re: Xfinity Xfi app not working

Delrayme, the team has fixed this issue for you. Please try logging into xFi again and let us know if you run into any other issues. 

New Poster

Re: Xfinity Xfi app not working

I am also having the same problem. Upgraded the Gateway and everything is running fine except for the app!
New Poster

Re: Xfinity Xfi app not working

I am having the same issue. Help!

Official Employee

Re: Xfinity Xfi app not working


wrote:

I am having the same issue. Help!


I just took a look and it appears the issue may have resolved itself. Can you please try accessing xFi and let me know if you still experience an error?

Thanks!