Community Forum

Xfi pods not coming online

New Poster

Xfi pods not coming online

I have had 2 sets of pods sent to me and have same issue they will not come online. Any suggestions? Thanks
Highlighted
Official Employee

Re: Xfi pods not coming online

bmerch - Thanks for reaching out.  I pulled up your account & see an open ticket for this issue.  It looks like you're already working with an agent to troubleshoot.  If you need further assistance with this issue, please let me know!


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Xfi pods not coming online

I've the same problem - unable to activate the pods...  spent several VERY frustrating hours with difeerent 'agents' who suggested conflicting solutions that did not work.  I was told by one 'agent' to actually return the pods for a refund!  

Official Employee

Re: Xfi pods not coming online

Marty11224 - I was able to pull up your account & it looks like all your Pods are online. Can you please let me know if you need any further troubleshooting help?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!