Community Forum

Xfi Pods slowing internet down

New Poster

Xfi Pods slowing internet down

So I've been dealing with dead spots through out my house and decided to invest in a pack of 6 pods to distribute through my 3 story 5 bedroom house. After getting them installed and all connected and online my speeds have drastically dropped. I'm seeing on average about 30Mbs which is unacceptable as I work from home and I pay for premium speeds with speed boost. The only devices in my house not affected are the ones that are hardlined. The dead spots I had problems with still experiance intermittent connectivity and the devices that used to work fine are now bottle necked. Not impressed especially considering the price, I had hoped that by purchasing vendor specific devices that I'd have a better experiance.. I was wrong. 

New Poster

Re: Xfi Pods slowing internet down

Same here...going to connect another router to the COMCAST modem
When your device jumps on the pod it runs at 25 to 34 or at least that’s what I’ve found
Silver Problem Solver

Re: Xfi Pods slowing internet down


@Jasmaz7 wrote:
Same here...going to connect another router to the COMCAST modem
When your device jumps on the pod it runs at 25 to 34 or at least that’s what I’ve found

I chose to pay extra for the Orbi because its wifi is faster than the xFi Pods.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!